Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#960 closed defect (duplicate)

Adding a slave zone to zonemgr gives an error if CLASS is not defined

Reported by: shane Owned by:
Priority: medium Milestone:
Component: configuration Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Medium
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

> config add Zonemgr/secondary_zones
> config show Zonemgr/secondary_zones
Zonemgr/secondary_zones[0]/class	"IN"	string	(default)
Zonemgr/secondary_zones[0]/name	""	string	(default)
> config set Zonemgr/secondary_zones[0]/name "time-travellers.nl.eu.org"
> config commit
Error: 'class'
Configuration not committed
> config set Zonemgr/secondary_zones[0]/class "IN"
> config commit
>

The default is "IN", so I should not have to set the class to "IN", right?

Subtickets

Change History (3)

comment:1 Changed 8 years ago by jreed

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #897.

comment:2 in reply to: ↑ description Changed 8 years ago by jinmei

Replying to shane:

The default is "IN", so I should not have to set the class to "IN", right?

Right, and I think this is just an instance of a more generic problem:
as far as I read the code correctly, bindctl doesn't honor configuration
defaults *at all*.

comment:3 Changed 8 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.