Opened 9 years ago

Closed 6 years ago

#952 closed defect (wontfix)

msgq/cc multiple reads problem (and bad_alloc in b10-auth upon notify)

Reported by: jelte Owned by: UnAssigned
Priority: medium Milestone: Common Outstanding Tasks
Component: Unclassified Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

in ticket #931, Michal discovered that there is a problem with multiple reads in cc/session. A (partial?) fix was proposed, and a different workaround was counterproposed (see that ticket).

However, I also see problems that look like they are caused by the same or a very similar issue; upon notify, sometimes b10-auth aborts with a bad_alloc. The bad_alloc is caused by it trying to create a buffer for a message of which the length was incorrectly read.

I think we should have locks around the different reads in session.cc

Subtickets

Change History (8)

comment:1 Changed 9 years ago by shane

  • Milestone New Tasks deleted

comment:2 Changed 6 years ago by muks

  • Milestone set to Sprint-20130903
  • Summary changed from msgq/cc multiple reads problem (and bad_alloc in b10-auth upon notify) to [kean] msgq/cc multiple reads problem (and bad_alloc in b10-auth upon notify)

comment:3 Changed 6 years ago by kean

  • Owner set to kean
  • Status changed from new to accepted

comment:4 Changed 6 years ago by kean

I need a little more information in order to proceed with this ticket. How can I reproduce this? The description is relatively vague and pouring over #931 didn't yield any particular insight.

comment:5 Changed 6 years ago by kean

  • Owner changed from kean to UnAssigned
  • Status changed from accepted to assigned

comment:6 Changed 6 years ago by kean

  • Summary changed from [kean] msgq/cc multiple reads problem (and bad_alloc in b10-auth upon notify) to msgq/cc multiple reads problem (and bad_alloc in b10-auth upon notify)

comment:7 Changed 6 years ago by stephen

  • Milestone changed from bind10-1.2-release-freeze to Common Outstanding Tasks

comment:8 Changed 6 years ago by tomek

  • Resolution set to wontfix
  • Status changed from assigned to closed
  • Version set to git

This issue is related to bind10 code that is no longer part of Kea.

If you are interested in BIND10/Bundy framework or its DNS components,
please check http://bundy-dns.de.

Closing ticket.

Note: See TracTickets for help on using tickets.