Opened 9 years ago

Closed 6 years ago

#892 closed enhancement (complete)

move generic test utils from lib/dns/tests to lib/util/unittests

Reported by: jinmei Owned by: UnAssigned
Priority: medium Milestone: Remaining BIND10 tickets
Component: build system Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

As I commented in #813, I propose:

  • move things except DNS specific things (matchName and createRequestMessage) in lib/dns/tests/unittest_util to lib/util/unittests/
  • unify addDataPath and (part of) readWireData with lib/util/unittests/testdata. basically I'd keep the latter and remove the duplicate functionality from the former.
  • in addition I'd change the interface of matchWireData() so that expected data is given before the actual data in the parameter list to be more comatible with other gtest interfaces (and variable names should be renamed to actual/expect, etc)

Subtickets

Change History (5)

comment:1 Changed 9 years ago by jinmei

  • Owner changed from jreed to UnAssigned
  • Status changed from new to assigned

comment:2 Changed 9 years ago by shane

  • Milestone changed from New Tasks to Year 3 Task Backlog

comment:3 in reply to: ↑ description Changed 6 years ago by muks

Replying to jinmei:

  • in addition I'd change the interface of matchWireData() so that expected data is given before the actual data in the parameter list to be more comatible with other gtest interfaces (and variable names should be renamed to actual/expect, etc)

This part is taken care of by #2168.

comment:4 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:5 Changed 6 years ago by tomek

  • Resolution set to complete
  • Status changed from assigned to closed
  • Version set to bind10-old
Note: See TracTickets for help on using tickets.