Opened 9 years ago

Closed 8 years ago

#809 closed task (complete)

Create tickets for remaining RR types

Reported by: stephen Owned by:
Priority: medium Milestone:
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

This is an administrative task, as it just involves creating 50 or so tickets. Notes concerning estimates for these tasks:

  • If we don't use a lexer/parser, then for each type, we will need to implement the methods (defined in abstract RDATA type) toText()/fromText()/toWire()/fromWire(). We will also need access to individual RDATA fields.
  • The code won't warn on deprecated types (at least for now).
  • We don't have convenience functions in Python now (may add them later).
  • DLV processing will be affected if we want to support it.

Subtickets

Change History (6)

comment:1 Changed 9 years ago by shane

  • Defect Severity set to N/A
  • Sub-Project set to DNS

The definitive list of RR types is here:

http://www.iana.org/assignments/dns-parameters

The doxygen documentation for the RRType implementation, which contains static functions for all defined types, is here:

http://bind10.isc.org/~jreed/doxygen/cpp/classisc_1_1dns_1_1_r_r_type.html

The doxygen documentation for the RDATA classes is here:

http://bind10.isc.org/~jreed/doxygen/cpp/classisc_1_1dns_1_1rdata_1_1_rdata.html

Note that as of today this documentation is slightly out of date, as the RP type has been implemented but is not in our web page yet. The source code at bind10/src/lib/dns/rrtype.h should be inspected to be certain.

comment:2 Changed 9 years ago by shane

There are several categories of missing RR types:

  • standard types, defined in IETF RFCs
  • standard types, defined in other documents
  • experimental types, defined in IETF RFCs
  • obsolete types, defined in IETF RFCs
  • proposed types, published in IETF drafts
  • old proposed types, published in expired IETF drafts

I propose to use the priority 'minor' for standard types, and 'trivial' for all other types. None of these is very important, but some are even less important than others!

comment:3 Changed 9 years ago by shane

After looking at the list, I decided not to create tickets for a few of the RR types:

  • NINFO and RKEY were proposed by Jim Reid in 2009 but he has since moved on to another job and it is likely those ideas will not go forward.
  • TALINK is currently being discussed on the DNS extensions working list and is probably not finalized yet.
  • CDS is currently being discussed on the DNS extensions working list and is probably not finalized yet.
  • URI is currently being developed and should not be considered finalized yet (although likely will go forward without too much change).
  • CAA is currently being developed and should not be considered finalized yet, as the working group is still in rapid flux.
  • TA was designed to solve the problem of the root not being signed. This problem has passed, so probably is not needed.

comment:5 Changed 9 years ago by shane

  • Milestone changed from Year 3 Task Backlog to Next-Sprint-Proposed

comment:6 Changed 8 years ago by shane

  • Milestone Next-Sprint-Proposed deleted
  • Resolution set to complete
  • Status changed from new to closed

As reported, this work was done.

Note: See TracTickets for help on using tickets.