Opened 9 years ago

Closed 9 years ago

#708 closed defect (fixed)

Strange RTT values when acting as a forwarder

Reported by: shane Owned by: stephen
Priority: medium Milestone: Sprint-20110419
Component: resolver Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 3.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Jeremy has BIND 10 set up as a forwarder, and got strange RTT values reported:

[b10-resolver] RTT: 3309575864

Stephen says that the base time for a fetch is set by the sendTo() function, but not the send() function. The send() function is used by forwarders.

The simple answer is to set the start time of a fetch in the send() function.

Subtickets

Change History (11)

comment:1 Changed 9 years ago by shane

  • Owner changed from shane to stephen
  • Status changed from new to assigned

I've put a 2-line fix for this into git as the trac708 branch. I can't think of a proper test for this right now. I'm going to hand it to Stephen, since hopefully it is not too difficult to add to the NSAS tests, however they work. (Lazy of me, I know, but this is a late, last-minute fix.)

comment:2 Changed 9 years ago by shane

See ticket #706 for more information.

comment:3 Changed 9 years ago by jreed

I am testing commit 3399d44c2d83f81b92a30bec360b3f207029bc3e. It appears to work, but since I can't reproduce I will wait for awhile.

comment:4 Changed 9 years ago by jreed

By the way, before the patch, I always had RTT: 0 or some nonsense like RTT: 3308037792.

After the patch, I have more sane output like RTT: 0 or RTT: 409 or RTT: 76.

comment:5 Changed 9 years ago by shane

At Jeremy's request I have merged this into master. I'm leaving the ticket open until we can get some tests written though.

comment:6 Changed 9 years ago by stephen

  • Milestone R-Team-Task-Backlog deleted

Milestone R-Team-Task-Backlog deleted

comment:7 Changed 9 years ago by stephen

  • Milestone set to Sprint-20110405

comment:8 Changed 9 years ago by stephen

  • Owner changed from stephen to shane

The test is in branch trac708_test. (As the change was committed to master, a new branch was taken from the latest version to minimise work when merging the result.)

comment:9 Changed 9 years ago by stephen

  • Status changed from assigned to reviewing

comment:10 Changed 9 years ago by shane

  • Owner changed from shane to stephen

The test looks reasonable. Please merge, thanks!

comment:11 Changed 9 years ago by stephen

  • Estimated Difficulty changed from 0.0 to 3
  • Resolution set to fixed
  • Status changed from reviewing to closed

Merged as commit 66c4f9e1df9c4c00d117323d016cca1c16c13e01

Note: See TracTickets for help on using tickets.