Opened 9 years ago

Closed 8 years ago

#693 closed defect (duplicate)

b10-resolver doesn't honor the default config spec

Reported by: jinmei Owned by: jelte
Priority: medium Milestone: Sprint-20110712
Component: resolver Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

For example, even if the spec says it listens on the localhost addresses
by default:

      {
        "item_name": "listen_on",
        "item_type": "list",
        "item_optional": false,
        "item_default": [
          {
            "address": "::1",
            "port": 53
          },
          {
            "address": "127.0.0.1",
            "port": 53
          }
        ]
...

It doesn't seem to listen on any address unless we explicitly configure it so.

FWIW, b10-auth explicitly gets the default configuration and configures itself
based on it:

        auth_server->setConfigSession(config_session);
        configureAuthServer(*auth_server, config_session->getFullConfig());

Subtickets

Change History (6)

comment:1 Changed 9 years ago by stephen

  • Milestone R-Team-Task-Backlog deleted

Milestone R-Team-Task-Backlog deleted

comment:2 Changed 8 years ago by jinmei

  • Defect Severity set to N/A
  • Milestone set to Next-Sprint-Proposed
  • Sub-Project set to DNS

comment:3 Changed 8 years ago by jreed

I think this is a duplicate of #518. Please check.

comment:4 Changed 8 years ago by stephen

  • Milestone changed from Next-Sprint-Proposed to Sprint-20110712

comment:5 Changed 8 years ago by jelte

  • Owner set to jelte
  • Status changed from new to assigned

comment:6 Changed 8 years ago by jelte

  • Resolution set to duplicate
  • Status changed from assigned to closed

Just checked, it does indeed work as expected now. Got fixed in #999

Note: See TracTickets for help on using tickets.