Opened 9 years ago

Last modified 4 years ago

#635 assigned defect

Presence of old version of BIND10 may cause new build to fail

Reported by: stephen Owned by: stephen
Priority: medium Milestone: Outstanding Tasks
Component: build system Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Low
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Building from sources, if:

  • --prefix is specified on the ./configure command line
  • "make install" is run to install the software in the "prefix" directory

... a subsequent build of a later version of BIND10 may fail.

The set of commands that cause the build to fail on Ubuntu 10.04 are given in the attached file.

Removing the "prefix" directory allows the subsequent build to succeed.

Subtickets

Attachments (1)

BuildFail.sh (3.1 KB) - added by stephen 9 years ago.
Shell script to demonstrate problem

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by stephen

Shell script to demonstrate problem

comment:1 Changed 9 years ago by jelte

That script did not fail for me at the time (have not tried it now), but I do see the problem.

In my case i have an installed version from a branch (trac488), but when i compile master now it fails running one of the tests in server_common. trac499 does not even compile (at b1bc4d63d568d15f6b21a3c25a2848bea2553ff7):
/home/jelte/opt/bind10/lib/libresolve.so.0: undefined reference to `asiolink::IOFetch::IOFetch(int, asiolink::IOService&, isc::dns::Question const&, asiolink::IOAddress const&, unsigned short, boost::shared_ptr<isc::dns::OutputBuffer>&, asiolink::IOFetch::Callback*, int)'

I wondered if disabling rpath would fix this, but that only results in much more linker errors (note that i expect we'll need to provide the option to disable rpath anyway, as well as one to set it manually).

comment:2 Changed 8 years ago by shane

  • Defect Severity set to Low
  • Owner changed from jreed to stephen
  • Status changed from new to assigned
  • Sub-Project set to Core

I tried this ticket. I didn't use the versions in the BuildFail?.sh script, because it was still using log4cxx which we have moved from a long time ago. I tried the last release version (git version 79787f23a43c6630ac1dd2c5bba757995012bfb) upgrading to master and it worked fine.

Can we resolve this issue? Or is this still a problem?

comment:3 Changed 5 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:4 Changed 5 years ago by tomek

  • Milestone changed from Remaining BIND10 tickets to DHCP Outstanding Tasks
  • Priority changed from low to medium
  • Version set to git

Note: we should check if Kea carries over this issue. If not, close this bug. If yes, fix it.

comment:5 Changed 4 years ago by tomek

  • Milestone changed from DHCP Outstanding Tasks to Outstanding Tasks

Milestone renamed

Note: See TracTickets for help on using tickets.