Opened 9 years ago

Closed 9 years ago

#633 closed defect (fixed)

clang++ build failure on freebsd (again)

Reported by: jinmei Owned by: jinmei
Priority: very high Milestone: A-Team-Sprint-20110309
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 2.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Due to the upgrade of libtool (to 2.4) the workaround for clang++ on
freebsd8 didn't work. The newer version of libtool internally uses
$CXXFLAGS for shared library setups, so we need to fake CXXFLAGS as
well as CFLAGS in configure.ac to work this around.

The attached patch does this, and I confirmed it fixed the build
problem.

If someone can make a quick sanity check on this, that would be great,
but if that doesn't happen soon I'll merge it to master anyway as the
change is mostly trivial (with the understanding of the above
background) and it affected buildbot.

The new workaround could be user-visible, but I suspect not many use
clang++ so I don't plan to spam the changelog for this fix.

I'm also adding this to the current A team sprint due to its urgency,
and giving it an estimation of 2.

Subtickets

Attachments (1)

configure.ac.diff (1.4 KB) - added by jinmei 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by jinmei

comment:1 Changed 9 years ago by jinmei

  • Owner changed from jreed to UnAssigned
  • Status changed from new to reviewing

comment:2 Changed 9 years ago by vorner

  • Owner changed from UnAssigned to vorner
  • Status changed from reviewing to accepted

comment:3 follow-up: Changed 9 years ago by vorner

  • Owner changed from vorner to jinmei
  • Status changed from accepted to reviewing

Hello

I looked at it and it makes sense. I did test with g++ and it doesn't hurt it.

Also, I always thought that I have wrongly installed clang, because it never worked for me. Now at last configure goes trough, but then the compilation fails with segfault (which I would say is clang's fault and I don't think it's worth taking care of, it will be solved by their devs or gentoo devs).

Anyway, if someone with working clang environment could run the compilation, it would be nice, but I think it's OK to merge.

comment:4 in reply to: ↑ 3 Changed 9 years ago by jinmei

Replying to vorner:

I looked at it and it makes sense. I did test with g++ and it doesn't hurt it.

Okay, merged.

Also, I always thought that I have wrongly installed clang, because it never worked for me. Now at last configure goes trough, but then the compilation fails with segfault (which I would say is clang's fault and I don't think it's worth taking care of, it will be solved by their devs or gentoo devs).

Do you mean segfault in compiling clang(++) itself, or in compiling
BIND 10 with clang++? If it's the latter, it may be similar to the
issue worked around in trac #448. But in any case I agree it's not
worth pursuing unless you have another reason for using clang++.

Closing this ticket.

comment:5 Changed 9 years ago by jinmei

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.