Opened 9 years ago

Closed 8 years ago

#630 closed defect (duplicate)

sqlite3 database errors

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: data source Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I think this may be caused by having multiple bind10's running at same time. Need to research how this happens:

Traceback (most recent call last):
  File "/home/jreed/tmp/bind10-devel-20110224/src/lib/python/isc/datasrc/sqlite3_ds.py", line 81, in open
    cur.execute("SELECT version FROM schema_version")
sqlite3.OperationalError: no such table: schema_version

and in xfrout:

  File "/home/jreed/tmp/bind10-devel-20110224/src/lib/python/isc/datasrc/sqlite3_ds.py", line 36, in create
    cur.execute("CREATE TABLE schema_version (version INTEGER NOT NULL)")
sqlite3.OperationalError: table schema_version already exists

Subtickets

Change History (1)

comment:1 Changed 8 years ago by shane

  • Defect Severity set to N/A
  • Resolution set to duplicate
  • Status changed from new to closed
  • Sub-Project set to DNS

This seems to be the same as ticket #326.

Note: See TracTickets for help on using tickets.