Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#607 closed defect (fixed)

Server failed: Message rendering attempted without Rcode set

Reported by: jreed Owned by: jelte
Priority: very high Milestone: R-Team-Sprint-20110308
Component: resolver Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 2.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I crashed b10-resolver with:

dig -t ixfr=201001 foo
;; communications error to 127.0.0.1#53: end of file
[b10-resolver] Server failed: Message rendering attempted without Rcode set
[bind10] Process b10-resolver (PID 19647) terminated, exit status = 256
[bind10] Resurrected b10-resolver (PID 18471)

Also that query became TYPE251. I don't understand why.

Subtickets

Change History (8)

comment:1 Changed 9 years ago by jreed

I know now that 251 is the IXFR query type.

I can also reproduce this by asking for TYPE252.

comment:2 Changed 9 years ago by jreed

  • Milestone changed from R-Team-Task-Backlog to R-Team-Sprint-20110308

comment:3 Changed 9 years ago by jelte

  • Owner set to jelte
  • Status changed from new to assigned

comment:4 Changed 9 years ago by jelte

  • Owner changed from jelte to UnAssigned
  • Status changed from assigned to reviewing

Okay, I have a dirty fix for this. Originally I figured we might as well do some planned refactors in this code while i was digging around in it, but those are much more invasive than I initially thought (the effects reach out to a few lib/ things, and more importantly, all the way out to bin/auth), I'll create a separate ticket for those (since i have most of that code already).

This fix just makes sure that some values in answer_message are set, even though, for immediate errors, answer_message isn't actually used (the error response is directly rendered, but the rest of the resolver code assumes it does use answer_message, which caused the problem)

comment:5 Changed 9 years ago by stephen

  • Owner changed from UnAssigned to stephen

comment:6 Changed 9 years ago by stephen

  • Owner changed from stephen to jelte

Seems to fix the problem. Please merge.

comment:7 Changed 9 years ago by jelte

  • Resolution set to fixed
  • Status changed from reviewing to closed

Thanks, merged, closing ticket.

comment:8 Changed 9 years ago by jelte

  • Estimated Difficulty changed from 0.0 to 2
Note: See TracTickets for help on using tickets.