Opened 9 years ago

Closed 9 years ago

#589 closed defect (fixed)

resolver is not closing TCP connections

Reported by: jreed Owned by: jelte
Priority: very high Milestone: R-Team-Sprint-20110316
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 1.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

[b10-resolver] Server failed: Too many open files
[bind10] Process b10-resolver (PID 25251) terminated, exit status = 256
[bind10] Resurrected b10-resolver (PID 321)

Growing:

t1:bind10$ fstat | grep b10-resolver | wc -l 
      49
t1:bind10$ fstat | grep b10-resolver | wc -l 
      64
t1:bind10$ fstat | grep b10-resolver | tail -3
root     b10-resolver 27119   66* internet stream tcp ffff800001f41948 127.0.0.1:53 <-> 127.0.0.1:55490
root     b10-resolver 27119   67* internet stream tcp ffff800002b33008 127.0.0.1:53 <-> 127.0.0.1:55489
root     b10-resolver 27119   68* internet stream tcp ffff800002b33950 127.0.0.1:53 <-> 127.0.0.1:55488

I run resolver continuously since mid December. I reinstalled once yesterday and once today. So I think is a regression in past 24 hours or so. I didn't bisect. Looks like only dab32ddc42b4707968fbc056261c50d4fa08e408 is related.

Subtickets

Change History (10)

comment:1 Changed 9 years ago by jreed

It was not that asiolink commit.

My problem started when I enabled the b10-auth server.

zonemgr/xfrin is doing tcp connections.

comment:2 Changed 9 years ago by jreed

To be clear, the problem is not with zonemgr/xfrin, but with tcp with queries. I can easily reproduce with dig +tcp.

comment:3 Changed 9 years ago by jreed

  • Milestone changed from feature backlog item to R-Team-Sprint-20110308
  • Summary changed from resolver is not closing connections to resolver is not closing TCP connections

comment:4 Changed 9 years ago by jelte

  • Owner set to jelte
  • Status changed from new to assigned

comment:5 Changed 9 years ago by jreed

bf57a576ff80578d47471569a48f0fbfd1fb6e2e works for me. I don't have old connections left.

Please open new ticket regarding keeping the TCP connection open (such as RFC 1035 4.2.2).

comment:6 Changed 9 years ago by jelte

  • Owner changed from jelte to UnAssigned
  • Status changed from assigned to reviewing

Do we need to do anything more that just close()? (shutdown? wait for reads to occur?)

comment:7 Changed 9 years ago by jelte

  • Estimated Difficulty changed from 0.0 to 1

comment:8 Changed 9 years ago by stephen

  • Owner changed from UnAssigned to stephen

comment:9 Changed 9 years ago by stephen

  • Owner changed from stephen to jelte

Looks OK, and Jeremy has confirmed that it has fixed the problem, so ahead and merge.

comment:10 Changed 9 years ago by jelte

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.