Opened 9 years ago

Closed 9 years ago

#572 closed defect (fixed)

Remove boss's -f

Reported by: vorner Owned by: vorner
Priority: low Milestone: A-Team-Sprint-20110223
Component: ~Boss of BIND (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 1.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Currently, Boss decides according to configuration if it should start auth or resolver (or both or none). However, it still accepts
the -f argument, which behaves strangely.

The -f needs an address, but that one is ignored, because the resolver reads it from configuration file.

If -f is provided, it starts resolver instead of auth, which can lead to unexpected behaviour (for example, if it was configured to start both, it starts resolver twice).

Furthermore, I didn't find -f mentioned in the manpage (actually, I didn't find it mentioned in any documentation, but I'm not sure I search all the places).

Therefore, -f should be probably removed, which is what this branch does.

Subtickets

Change History (5)

comment:1 Changed 9 years ago by vorner

  • Owner changed from vorner to UnAssigned
  • Status changed from new to reviewing

It is ready for review.

There are no tests, as this only removes code (and functionality, even if it is unwanted one) and that piece of code was untested.

Changelog:

[bug]     vorner
Boss no longer has the -f argument, which was undocumented and stayed as
a relict of previous versions, currently causing only strange behaviour.

comment:2 Changed 9 years ago by jinmei

It seems we don't need the temporary variable 'dns_prog' any more:

        dns_prog = 'b10-auth'
        dnsargs = [dns_prog]

For that matter, I'd rename dnsargs to something like "authargs" using
this opportunity.

Other than these the changes look okay.

comment:3 Changed 9 years ago by jinmei

  • Owner changed from UnAssigned to vorner

comment:4 Changed 9 years ago by jinmei

One more thing: according to the previous sprint planning meeting
you're expected to provide the estimation of the task size.

comment:5 Changed 9 years ago by vorner

  • Estimated Difficulty changed from 0.0 to 1
  • Resolution set to fixed
  • Status changed from reviewing to closed

OK, I renamed the variable and merged. Thanks.

And I estimate I did it a short time, so let's say it's 1.

Note: See TracTickets for help on using tickets.