Opened 19 months ago

Closed 16 months ago

Last modified 16 months ago

#5635 closed defect (worksforme)

Client get ip address problem

Reported by: m313353 Owned by:
Priority: medium Milestone: Kea1.5
Component: dhcp Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

The server is configured with multiple subnets. Client already
Get a subnet's IP address, then access another subnet (vlan1 to
Vlan2, 172.16.0.0/24 to 10.10.100.0/24), the client IP address gets slow (
It takes 60 seconds to get the IP address)

Subtickets

Attachments (1)

kea dhcp.jpg (73.0 KB) - added by m313353 19 months ago.

Download all attachments as: .zip

Change History (5)

Changed 19 months ago by m313353

comment:1 Changed 18 months ago by marcin

  • Milestone changed from Kea1.x to Kea-proposed

This bug report contains too little information to tell what is wrong. It may also be the case that there is nothing wrong. The screenshot provided with the bug report implies the following:

  • The client is sending DHCPREQUEST multiple times to the server.
  • The server ignores those requests
  • The client receives no response from the server so it falls back to 4-way exchange and gets a lease.

What I can't tell from this capture is:

  • Whether the requests come from the same client
  • Whether the requests are sent to a particular server or to any server

The most likely scenario seems to be that the client has a lease and then reboots. The client is then in the INIT-REBOOT state when it remembers its lease and checks whether the lease is still valid. The client sends DHCPREQUESTs without specifying server-id but specifying requested IP address. The server receives those requests but can't find a lease for this client (not sure whether this lease is still there or not). Because there is no lease, it ignores the requests thinking that there is some other server which has allocated the lease. The client tries several times until it gives up and does 4-way exchange.

Without more detailed traffic capture I can't really tell what is happening. If the scenario is as described above, there is no bug here.

comment:2 Changed 17 months ago by tomek

Hey m313353, are you still interested in this problem? Can you provide more information? What sort of a client that was? which Kea version are you running? What was the client doing? Is this something that happened only once? Can you reproduce the problem in your network? Can you share kea logs an kea config?

If you don't answer within a week or two, we'll need to close this ticket as there's nothing we can do about it.

Last edited 17 months ago by tomek (previous) (diff)

comment:3 Changed 16 months ago by tomek

  • Resolution set to worksforme
  • Status changed from new to closed

It's been a long time and we haven't heard from the original submitter. We can't do anything with this ticket without extra info, so closing.

comment:4 Changed 16 months ago by tomek

  • Milestone changed from Kea-proposed to Kea1.5
Note: See TracTickets for help on using tickets.