Opened 9 years ago

Closed 9 years ago

#560 closed defect (fixed)

urgent fix to log4cxx regression: allow disabling it

Reported by: jinmei Owned by: UnAssigned
Priority: very high Milestone: R-Team-Sprint-20110208
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Apparently the log4cxx regression won't soon be fixed. Since it's already
making autobuild fail for several days, we need an urgent quick hack fix.

The proposed patch (attached) allows --without-log4cxx in configure.ac,
which simply disables building log4cxx-related sources and tests.

It also removes the dependency on liblog in b10-auth, which currently
doesn't use the logging library.

I confirmed it worked both with or without cases.

Subtickets

Attachments (1)

log4cxx-urgentfix.diff (2.2 KB) - added by jinmei 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by jinmei

comment:1 Changed 9 years ago by jinmei

Could someone quickly review it? It's small and mostly trivial.

comment:2 Changed 9 years ago by jinmei

  • Owner changed from jreed to UnAssigned
  • Status changed from new to reviewing

comment:3 Changed 9 years ago by jinmei

  • Resolution set to fixed
  • Status changed from reviewing to closed

okayed on jabber, pushed. closing ticket.

Note: See TracTickets for help on using tickets.