Opened 10 years ago

Closed 10 years ago

#54 closed enhancement (wontfix)

naming convention: RRSet vs RRset

Reported by: jinmei Owned by: jinmei
Priority: low Milestone:
Component: libdns++ Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: Add Hours to Ticket:
Total Hours: Internal?:


The current DNS message library has a class named "RRset".

It's not "RRSet" to be compatible with the seeming consensus at the
IETF namedroppers ML:

/ Note about terminology: there has been a discussion at the IETF
/ namedroppers ML about RRset vs RRSet (case of "s")
/ While RFC2181 uses the latter, many other RFCs use the former,
/ and most of the list members who showed their opinion seem to prefer
/ "RRset". We follow that preference in this implementation.

On the other hand, it's inconsistent with other similar types, RRType,
RRClass, and RRTTL, and may annoy developers for possible mistyping,

To make these consistent, there are mainly two options:

  1. RRset, RRtype, RRclass, RRttl
  2. RRSet, RRType, RRClass, RRTTL

The 1st option is compatible with the IETF "rough consensus"
convention, but may look a bit awkward in that we use lower case
letters for the acronym "ttl".

The 2nd option has the reversed pro/con.

We're not really sure which is better, but we at least agree code
level consistency should be the most important point, so we'll need to
change them anyway.

This is a relatively minor issue, so we'll revisit this after year-1


Change History (1)

comment:1 Changed 10 years ago by shane

  • Resolution set to wontfix
  • Status changed from new to closed

Would be nice to have RRSet for consistency, but consensus is it is not important. Closing!

Note: See TracTickets for help on using tickets.