Opened 3 years ago

Closed 3 years ago

#5064 closed defect (fixed)

legal_logging hook lib is not installed with make install

Reported by: tomek Owned by: fdupont
Priority: low Milestone: Kea1.2
Component: build system Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 2
Total Hours: 0 Internal?: no

Description

This problem affects both user_chk and legal_logging libraries. They're compiled, but not installed.

Hopefully the fix is trivial - just remove noinst from noinst_LTLIBRARIES in appropriate Makefile.ams.

Subtickets

Change History (12)

comment:1 Changed 3 years ago by tomek

  • Milestone changed from Kea-proposed to Kea1.2
  • Priority changed from medium to low
  • Summary changed from user_chk and legal_logging hook libs are not installed with make install to legal_logging hook lib is not installed with make install

This was discussed on 2016-12-08 meeting and we decided the proper way to go is to install legal_logging (because it's production code) and don't install user_chk (because it's more of a demonstration rather than a production code.

Also, since this work is not directly related to the 1.2 goals, we're accepting it as low.

comment:2 Changed 3 years ago by fdupont

  • Owner set to fdupont
  • Status changed from new to accepted

comment:3 Changed 3 years ago by fdupont

  • Add Hours to Ticket changed from 0 to 2
  • Owner changed from fdupont to UnAssigned
  • Status changed from accepted to reviewing

Done: now the hook library is installed in $(libdir)/hooks.
Ready for review.

comment:4 Changed 3 years ago by tmark

  • Owner changed from UnAssigned to tmark

comment:5 Changed 3 years ago by tmark

  • Owner changed from tmark to fdupont

The library does not get installed.

Did you not push changes? I pulled premium/trac5064 and the last entry in its git log is:

commit 9a49d798531d8c0f9c6f1f5caabf3ab353df0ec1
Author: Tomek Mrugalski <tomasz@isc.org>
Date:   Thu Feb 9 16:17:27 2017 +0100

    [master] ChangeLog updated after #5131 merge.

comment:6 Changed 3 years ago by fdupont

I remember the git config for submodule is a bit special so I am checking...

comment:7 Changed 3 years ago by fdupont

  • Owner changed from fdupont to tmark

I followed the KeaPremium? stuff and got a trac5064 with no new log but a diff with master. BTW the diff seems correct (I remember the fix was trivial).

comment:8 follow-up: Changed 3 years ago by tmark

  • Owner changed from tmark to fdupont

Ok, there is indeed a change to Makefile.am but I don't think it was the correct change. The libdhcp_legal_log does not get installed anywhere when you run "make install". It should be installed in <prefix>/lib right?

comment:9 in reply to: ↑ 8 ; follow-up: Changed 3 years ago by fdupont

  • Owner changed from fdupont to tmark

Replying to tmark:

Ok, there is indeed a change to Makefile.am but I don't think it was the correct change. The libdhcp_legal_log does not get installed anywhere when you run "make install". It should be installed in <prefix>/lib right?

=> no, I added a hooks in the path to avoid confusion between hooks DSOs and kea libraries.

comment:10 in reply to: ↑ 9 Changed 3 years ago by tmark

  • Owner changed from tmark to fdupont

Replying to fdupont:

Replying to tmark:

Ok, there is indeed a change to Makefile.am but I don't think it was the correct change. The libdhcp_legal_log does not get installed anywhere when you run "make install". It should be installed in <prefix>/lib right?

=> no, I added a hooks in the path to avoid confusion between hooks DSOs and kea libraries.

And that is fine with me. The problem is the library does not get installed anywhere, at all. I ran make install in both the main source directory and the premium directory and the library does not get installed anywhere on my MAC:

tmark@pegasus sanity $ locate libdhcp_legal_log
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/.libs/libdhcp_legal_log.a
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/.libs/libdhcp_legal_log.la
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/.libs/libdhcp_legal_log.lai
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/.libs/libdhcp_legal_log.so
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/libdhcp_legal_log.dox
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/libdhcp_legal_log.la
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/libloadtests/.deps/libdhcp_legal_log_unittests-load_unload_unittests.Po
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/libloadtests/.deps/libdhcp_legal_log_unittests-run_unittests.Po
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/libloadtests/.libs/libdhcp_legal_log_unittests
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/libloadtests/libdhcp_legal_log_unittests
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/libloadtests/libdhcp_legal_log_unittests-load_unload_unittests.o
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/libloadtests/libdhcp_legal_log_unittests-run_unittests.o
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/tests/.deps/libdhcp_legal_log_unittests-legal_log4_unittests.Po
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/tests/.deps/libdhcp_legal_log_unittests-legal_log6_unittests.Po
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/tests/.deps/libdhcp_legal_log_unittests-rotating_file_unittests.Po
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/tests/.deps/libdhcp_legal_log_unittests-run_unittests.Po
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/tests/.libs/libdhcp_legal_log_unittests
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/tests/libdhcp_legal_log_unittests
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/tests/libdhcp_legal_log_unittests-legal_log4_unittests.o
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/tests/libdhcp_legal_log_unittests-legal_log6_unittests.o
/Users/tmark/keadev/review/prem/premium/src/hooks/dhcp/legal_log/tests/libdhcp_legal_log_unittests-rotating_file_unittests.o

comment:11 Changed 3 years ago by tmark

In reviewing 5080 it appears that you corrected the library installation in master?

commit b0c01c83336db25d257845acd0235cc69024ac5e
Author: Francis Dupont <fdupont@…>
Date: Mon Feb 13 13:38:17 2017 +0100

Installed legal log library

diff --git a/src/hooks/dhcp/legal_log/Makefile.am b/src/hooks/dhcp/legal_log/Makefile.am
index 8d7883e..d2431cf 100644
--- a/src/hooks/dhcp/legal_log/Makefile.am
+++ b/src/hooks/dhcp/legal_log/Makefile.am
@@ -54,7 +54,9 @@ if USE_CLANGPP

liblegl_la_CXXFLAGS += -Wno-unused-parameter
endif

-noinst_LTLIBRARIES += libdhcp_legal_log.la
+# install the shared object into $(libdir)/hooks
+lib_hooksdir = $(libdir)/hooks
+lib_hooks_LTLIBRARIES = libdhcp_legal_log.la

libdhcp_legal_log_la_SOURCES =
libdhcp_legal_log_la_LDFLAGS = $(AM_LDFLAGS)

So it would appear that this ticket has been resolved without trac5064.

Last edited 3 years ago by tmark (previous) (diff)

comment:12 Changed 3 years ago by fdupont

  • Resolution set to fixed
  • Status changed from reviewing to closed

Fix was merged so the ticket can be closed.

Note: See TracTickets for help on using tickets.