Opened 9 years ago

Closed 9 years ago

#501 closed enhancement (complete)

NSAS Glue Corrections

Reported by: shane Owned by: jelte
Priority: low Milestone: R-Team-Sprint-20110316
Component: resolver Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 10.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

NSAS Glue Corrections

  • Add relevant glue as information to queries between Resolver and NSAS
  • Add method to resolver to tell it to return glue if information is not in the cache

Subtickets

Change History (7)

comment:1 Changed 9 years ago by jelte

  • Owner set to jelte
  • Status changed from new to assigned

comment:2 Changed 9 years ago by jelte

  • Owner changed from jelte to UnAssigned
  • Status changed from assigned to reviewing

trac501, commit 610400fa75aa44d15fdc95dc8b69e02b45698765
(branch is branched off trac495, but only this commit is relevant)

comment:3 Changed 9 years ago by stephen

  • Owner changed from UnAssigned to stephen

comment:4 follow-up: Changed 9 years ago by stephen

  • Owner changed from stephen to jelte

src/lib/nsas/glue_hints.{cc,h}
A message is being output to stdout in the GlueHints constructor.

A matter of preference, but as they are very much tied to glue - and take as arguments the address vectors (i.e. all the member variables of the GlueHints class) - I would suggest that addGlueForRRset() and addGlueForName() are better defined as private methods in the class.

src/lib/nsas/nameserver_address.h
Why was the "nameserver" argument in the NameserverAddress constructor changed from passed by reference to being passed by value?

src/lib/resolve/recursive_query.cc
Not really related to this change, but the variable found_ns_address is mis-named as it only indicates whether an NS record has been found - found_ns is better.

comment:5 in reply to: ↑ 4 Changed 9 years ago by jelte

  • Owner changed from jelte to stephen

Replying to stephen:

src/lib/nsas/glue_hints.{cc,h}
A message is being output to stdout in the GlueHints constructor.

oops removed.

A matter of preference, but as they are very much tied to glue - and take as arguments the address vectors (i.e. all the member variables of the GlueHints class) - I would suggest that addGlueForRRset() and addGlueForName() are better defined as private methods in the class.

Ack. Initially I had everything as private, which didn't make sense. I guess i overdid it a bit :)

src/lib/nsas/nameserver_address.h
Why was the "nameserver" argument in the NameserverAddress constructor changed from passed by reference to being passed by value?

oops, I was doing some experimenting regarding a null shared_ptr, and was wondering if passing them by reference if you know you'll copy them was a bad idea or not (still not entirely sure about that, btw). Re-added the ref.

src/lib/resolve/recursive_query.cc
Not really related to this change, but the variable found_ns_address is mis-named as it only indicates whether an NS record has been found - found_ns is better.

ack. Changed it.

See commit 629023f290c290441129c96b11ece7de299fb8a6

comment:6 Changed 9 years ago by stephen

  • Owner changed from stephen to jelte

All looks OK, please merge.

comment:7 Changed 9 years ago by jelte

  • Resolution set to complete
  • Status changed from reviewing to closed

Thanks! Closing ticket

Note: See TracTickets for help on using tickets.