Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#477 closed defect (duplicate)

bindctl should exit gracefully after "Boss shutdown"

Reported by: jinmei Owned by:
Priority: medium Milestone:
Component: ~bind-ctl (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Currently its behavior is weird:

% bindctl 
["login success "] login as root
> Boss shutdown
send the command to cmd-ctrld
received reply: {}
> quit
[Errno 61] Connection refused 
Failed to connect with b10-cmdctl module, is it running?

This might be understandable for a programmer, but doesn't make sense at all for normal operators.

Subtickets

Change History (4)

comment:1 Changed 9 years ago by jinmei

Oh, for that matter, I think this message doesn't look very nice either:

received reply: {}

comment:2 Changed 9 years ago by stephen

  • Milestone feature backlog item deleted

Milestone feature backlog item deleted

comment:3 Changed 8 years ago by vorner

  • Defect Severity set to N/A
  • Milestone set to New Tasks
  • Resolution set to duplicate
  • Status changed from new to closed
  • Sub-Project set to DNS

This is duplicate of #304.

comment:4 Changed 8 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.