Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#468 closed defect (fixed)

shutdown command doesn't work

Reported by: jinmei Owned by: UnAssigned
Priority: high Milestone: y2 12 month milestone
Component: ~bind-ctl (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

If I try "Boss shutdown" with bindctl on the latest trunk I get:

> Boss shutdown
send the command to cmd-ctrld
Error! 
Fail to connect with b10-cmdctl module, is it running?

And b10-cmdctl dumps a stack trace:

  File "/Users/jinmei/src/isc/bind10/trunk-reload/src/bin/cmdctl/b10-cmdctl", line 140, in do_POST
    rcode, reply = self._handle_post_request()
  File "/Users/jinmei/src/isc/bind10/trunk-reload/src/bin/cmdctl/b10-cmdctl", line 205, in _handle_post_request
    rcode, reply = self.server.send_command_to_module(mod, cmd, param)
  File "/Users/jinmei/src/isc/bind10/trunk-reload/src/bin/cmdctl/b10-cmdctl", line 549, in send_command_to_module
    return self.cmdctl.send_command_with_check(module_name, command_name, params)
  File "/Users/jinmei/src/isc/bind10/trunk-reload/src/bin/cmdctl/b10-cmdctl", line 382, in send_command_with_check
    if not spec_obj.validate_command(command_name, params, errors):
  File "/Users/jinmei/src/isc/bind10/trunk-reload/src/lib/python/isc/config/module_spec.py", line 116, in validate_command
    return _validate_spec_list(cmd['command_args'], True, cmd_params, errors)
  File "/Users/jinmei/src/isc/bind10/trunk-reload/src/lib/python/isc/config/module_spec.py", line 342, in _validate_spec_list
    for item_name in data:
TypeError: 'NoneType' object is not iterable

"sendstats" resulted in the same error. I suspect there's a regression for commands that don't take arguments.

Subtickets

Change History (3)

comment:1 in reply to: ↑ description Changed 9 years ago by jinmei

  • Owner set to UnAssigned
  • Status changed from new to reviewing

Replying to jinmei:

If I try "Boss shutdown" with bindctl on the latest trunk I get:

> Boss shutdown
send the command to cmd-ctrld
Error! 
Fail to connect with b10-cmdctl module, is it running?

branches/trac468 should fix the problem. Please review. IMO this bug must be fixed before the next release.

Proposed changlog entry:

  143.?	[bug]		jinmei
	Fixed a bug that control commands that don't take an argument
	were incorrectly considered invalid.  Due to this the "shutdown"
	command with bindctl didn't work.  This is a regression due to
	change #136. (Trac #468, svn rTBD)

comment:2 follow-up: Changed 9 years ago by jelte

  • Resolution set to fixed
  • Status changed from reviewing to closed

Ok, I added the tests in this branch too. Closing ticket.

BTW, I don't think this needs a changelog entry, as this bug had not made it to a release yet, so from a changelog point of view nothing has actually changed

comment:3 in reply to: ↑ 2 Changed 9 years ago by jinmei

Replying to jelte:

Ok, I added the tests in this branch too. Closing ticket.

BTW, I don't think this needs a changelog entry, as this bug had not made it to a release yet, so from a changelog point of view nothing has actually changed

Okay, that's fine for me.

Note: See TracTickets for help on using tickets.