Opened 9 years ago

Closed 9 years ago

#465 closed task (fixed)

Update query_bench for in memory data source

Reported by: jinmei Owned by: jinmei
Priority: medium Milestone: y2 12 month milestone
Component: b10-auth Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

This should be an easy task, so I did it.

I also found a bug in it, which is another regression due to the ASIO changes.

I'll create a branch for the patch.

Subtickets

Change History (3)

comment:1 Changed 9 years ago by jinmei

  • Owner changed from jinmei to UnAssigned
  • Status changed from new to reviewing

branches/trac465 is ready for review. It contains a single changeset, r4089.

Proposed changelog entry is this:

  142.?	[func]		jinmei
	b10-auth: updated query benchmark so that it can test in memory
	data source.  Also fixed a bug that the output buffer isn't
	cleared after query processing, resulting in misleading results
	or program crash.  This is a regression due to change #135.
	(Trac #465, svn rTBD)

This is relatively a lower priority task, but if someone has time for reviewing additional stuff, please review this.

comment:2 follow-up: Changed 9 years ago by vorner

  • Owner changed from UnAssigned to jinmei

The code seems OK.

Just one question. Would it make sense to try enabling the hotspot cache for the memory data source as well to see what effect on performance it has?

Anyway, this can be merged. If the hotspot for memory data source makes sense, we might as well open another ticket for it.

comment:3 in reply to: ↑ 2 Changed 9 years ago by jinmei

  • Resolution set to fixed
  • Status changed from reviewing to closed

Replying to vorner:

The code seems OK.

Okay, thanks for review. Merged to trunk.

Just one question. Would it make sense to try enabling the hotspot cache for the memory data source as well to see what effect on performance it has?

At least in its current form of hot spot cache, I don't think so. In memory data source should be fast enough. If we want to optimize it further with caching, I suspect it should be a higher level caching, such as caching a complete response message for very popular queries.

But in any case, as always for optimization related matters, we cannot be 100% without actual evaluation. If someone wants to try it with benchmarking (in future), I have no objection to that.

Anyway, this can be merged. If the hotspot for memory data source makes sense, we might as well open another ticket for it.

Okay, thanks again. Closing ticket.

Note: See TracTickets for help on using tickets.