Opened 3 years ago

Closed 10 months ago

#4530 closed enhancement (complete)

Add use of hardware address, type, and source to PostgreSQL lease manager

Reported by: tmark Owned by: razvan.becheriu
Priority: medium Milestone: Kea1.4
Component: database-all Version: git
Keywords: postgresql Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 16 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

The PosgreSQL 3.0 schema added the hardware address columns to the lease6 table under #4275. However, PgSqlLeaseMgr? neither reads nor writes them. It also appears that unit tests do not verify these values for any of the backends, so the unit tests in GenericLeaseMgr? likely need to be extended.

Subtickets

Change History (9)

comment:1 Changed 3 years ago by hschempf

  • Milestone changed from Kea-proposed to Outstanding Tasks

Per June 30 team meeting, move to Outstanding

comment:2 Changed 3 years ago by tomek

Also see #3557, which is kind of a duplicate of this ticket.

comment:3 Changed 3 years ago by tomek

We did receive a pull-request for this from Azerothian:
https://github.com/isc-projects/kea/pull/9.

comment:4 Changed 10 months ago by tomek

  • Milestone changed from Outstanding Tasks to Kea-proposed

This is being covered by github70, which is currently in review. Thus moving to proposed to keep an eye on this.

comment:5 Changed 10 months ago by tomek

  • Milestone changed from Kea-proposed to Kea1.4
  • Owner set to razvanbecheriu
  • Status changed from new to assigned

comment:6 Changed 10 months ago by tomek

  • Resolution set to complete
  • Status changed from assigned to closed

This ticket has been covered by github70 PR, which has just been merged.
Moving ticket to 1.4, assigning to razvan (to leave a note he did the work)
and closing.

comment:7 Changed 10 months ago by tomek

  • Resolution complete deleted
  • Status changed from closed to reopened

comment:8 Changed 10 months ago by tomek

  • Owner changed from razvanbecheriu to razvan.becheriu
  • Status changed from reopened to assigned

comment:9 Changed 10 months ago by tomek

  • Resolution set to complete
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.