Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#4315 closed defect (fixed)

python3 is required for enable-generate-docs

Reported by: fdupont Owned by: fdupont
Priority: low Milestone: Kea1.1
Component: Unclassified Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

On docs I got:
configure: error: "Python3 is required for enable-generate-docs"
which is IMHO a bug.

Subtickets

Change History (5)

comment:1 Changed 4 years ago by fdupont

  • Owner set to fdupont
  • Status changed from new to accepted

Modified PYTHON variable in config.status, rerun it and launch a make: no problem.
BTW I don't propose to remove python3 detection in configure because it is still used in:

  • src/lib/dns/gen-rdatacode.py.in
  • src/lib/util/python/gen_wiredata.py.in

but none is critical...

comment:2 Changed 4 years ago by tomek

  • Owner changed from fdupont to tomek
  • Status changed from accepted to assigned

comment:3 Changed 4 years ago by tomek

  • Owner changed from tomek to fdupont

The change is fine. It's sufficiently small that no changelog entry is necessary. If you want to add one, that's ok, too.

comment:4 Changed 4 years ago by fdupont

  • Resolution set to fixed
  • Status changed from assigned to closed

Merged (with a ChangeLog entry because it is user visible).

comment:5 Changed 4 years ago by fdupont

  • Milestone changed from Kea-proposed to Kea1.1
Note: See TracTickets for help on using tickets.