Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#4105 closed enhancement (complete)

4o6: Configuration parameter for 4o6-subnet in the DHCPv4 (config parser + structures)

Reported by: tomek Owned by: tomek
Priority: medium Milestone: Hackathon-ietf
Component: dhcp4o6 Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description (last modified by tomek)

This ticket covers adding:

  • 4o6-subnet
  • 4o6-interface

parameter in the Dhcpv4 configuration.

See http://kea.isc.org/wiki/Dhcp4o6Design for the details.

Subtickets

Change History (13)

comment:1 Changed 4 years ago by tomek

  • Description modified (diff)
  • Owner set to tomek
  • Status changed from new to assigned

comment:2 Changed 4 years ago by tomek

  • Milestone changed from Hackathon-ietf93 to Hackathon-ietf

Milestone renamed

comment:3 Changed 4 years ago by fdupont

I disagree with the 4o6-interface: IMHO it is enough to (re)use the already existing interface specification (i.e., it does't matter if the received packet is real DHCPv4 or DHCPv4-over-DHCPv6).

For the 4o6-subnet a prefix is not enough because of the interface-id.
In fd4o6 I used a subset of the subnet6. This allowed to reuse the subnet6 methods but required the matching subnet-id trick...

comment:4 Changed 4 years ago by tomek

  • Owner changed from tomek to UnAssigned
  • Status changed from assigned to reviewing

The code has been implemented. The parser accepts two new paramaters: 4o6-interface, 4o6-subnet. Please review. See branch trac4105.

comment:5 Changed 4 years ago by tomek

  • Owner changed from UnAssigned to tomek

comment:6 Changed 4 years ago by tomek

As discussed during the hackathon:

  • will add 4o6-interface-id option
  • there's a difference of opinions whether 4o6-interface is needed or not. Tomek thinks it is (because the v6 server may run on a different machine or use different interfaces that v4) and Francis thinks it's not needed, because both servers will run on the same machine and extra mapping would be required. The decision is to keep the 4o6-interface as is.

comment:7 Changed 4 years ago by tomek

  • Owner changed from tomek to UnAssigned

4o6-interface-id parameter implemented.

comment:8 Changed 4 years ago by fdupont

  • Owner changed from UnAssigned to fdupont

comment:9 Changed 4 years ago by fdupont

in dhcp4/json_config_parser.cc I have a style question about getOptionalParam() vs getParam() and ignore DhcpConfigError exceptions. Note it is a concern when the code in the try block itself raises DhcpConfigError.

dhcp4/tests/config_parser_unittest.cc: 4o6default: the comment says do not set 4o6 fields at all. (IMHO it is more does) but only enabled_ is checked for.

comment:10 Changed 4 years ago by fdupont

  • Owner changed from fdupont to tomek

dhcpsrv/subnet.h: extra/spurious blank line before dhcp4o6_ declaration?

comment:11 Changed 4 years ago by tomek

The changes have been implemented and Francis confirmed that the changes are good.

Code merged. Closing ticket.

comment:12 Changed 4 years ago by tomek

  • Resolution set to complete
  • Status changed from reviewing to closed

comment:13 Changed 4 years ago by tomek

  • Component changed from Unclassified to dhcp4o6
Note: See TracTickets for help on using tickets.