Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#4030 closed defect (duplicate)

distcheck failure because of unit test LoggingTest.basicSpec

Reported by: wlodekwencel Owned by:
Priority: medium Milestone: Kea1.0-beta
Component: logging Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

During distcheck (on Ubuntu, RedHat?, FreeBSD) we have unit test failure:
[ RUN ] LoggingTest?.basicSpec
../../../../../src/lib/dhcpsrv/tests/logging_unittest.cc:52: Failure
Expected: isc::config::moduleSpecFromFile(specfile) doesn't throw an exception.

Actual: it throws.

[ FAILED ] LoggingTest?.basicSpec (0 ms)

observed after #3752 was merged.

Subtickets

Change History (4)

comment:1 Changed 5 years ago by fdupont

Duplicate of #4026 (which provides the solution).

comment:2 Changed 5 years ago by fdupont

  • Resolution set to duplicate
  • Status changed from new to closed

Coling as #4026 is ready.

comment:3 Changed 5 years ago by hschempf

  • Milestone changed from Kea-proposed to Kea1.0

comment:4 Changed 4 years ago by tomek

  • Milestone changed from Kea1.0 to Kea1.0-beta

Milestone renamed

Note: See TracTickets for help on using tickets.