Opened 9 years ago

Closed 8 years ago

#376 closed enhancement (invalid)

Writable datasources: Ixfr module

Reported by: jelte Owned by: jelte
Priority: medium Milestone:
Component: data source Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

The Ixfr module should use the writable datasource API, instead of directly writing to the database.

(This is a subset of ticket #232)

Subtickets

Change History (5)

comment:1 Changed 9 years ago by jelte

  • Owner changed from jelte to UnAssigned
  • Status changed from new to reviewing
  • Type changed from defect to enhancement

Ready for review. Changes in branches/trac376 r3350.

There is a second commit; the unittests showed a lot of stacktraces. This was already present and not caused by the changes in this branch, but i thought i'd fix it anyway; these changes are in r3355.

comment:2 Changed 9 years ago by jelte

  • Owner changed from UnAssigned to jelte
  • Status changed from reviewing to accepted

Taking this out of the open review queue for now (depends on as-of-yet undecided changes to #374 and #375)

comment:3 Changed 9 years ago by jelte

  • Owner changed from jelte to UnAssigned
  • Status changed from accepted to assigned

Making it UnAssigned? (note that this still depends on whether #374 needs any change, in which case this branch will also need to be updated before it is reviewable)

comment:4 Changed 8 years ago by shane

  • Defect Severity set to N/A
  • Owner changed from UnAssigned to jelte
  • Sub-Project set to DNS

Like #375, unsure if this ticket is still relevant. Jelte?

comment:5 Changed 8 years ago by jelte

  • Resolution set to invalid
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.