Opened 5 years ago

Closed 3 years ago

#3557 closed enhancement (duplicate)

Extend Lease6 storage to cover MAC address (PostgreSQL)

Reported by: tomek Owned by: tomek
Priority: medium Milestone: Outstanding Tasks
Component: database-all Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Once #3555 is done, we'll need to extend MySQL to store MAC addresses.

Subtickets

Change History (7)

comment:1 Changed 5 years ago by hschempf

  • Milestone changed from Kea0.9.1 to Kea1.1

comment:2 Changed 4 years ago by tomek

We did receive a pull-request for this from Azerothian:
https://github.com/isc-projects/kea/pull/9.

I did review it quickly: https://github.com/isc-projects/kea/pull/9#issuecomment-99408897.

The proposed change looks more or less correct, but additional changes are required. I haven't tested it, though.

comment:3 Changed 4 years ago by tomek

  • Milestone changed from Kea1.1 to DHCP Outstanding Tasks

comment:4 Changed 4 years ago by tomek

  • Milestone changed from DHCP Outstanding Tasks to Outstanding Tasks

Milestone renamed

comment:5 Changed 3 years ago by tomek

See #4530, which is kind of a duplicate of this.

comment:6 Changed 3 years ago by tomek

  • Owner set to tomek
  • Status changed from new to assigned

comment:7 Changed 3 years ago by tomek

  • Resolution set to duplicate
  • Status changed from assigned to closed

Since the fields have been added and there's #4530 that is specific about actually using those fields, this ticket can be closed.

Please carry on any future work related to that in #4530.

Note: See TracTickets for help on using tickets.