Opened 9 years ago

Closed 9 years ago

#345 closed enhancement (fixed)

remove dependency on pthreads from asio

Reported by: jinmei Owned by: jinmei
Priority: low Milestone: y2 12 month milestone
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0.5 Internal?: no

Description

Right now we need to link some tests explicitly with libpthreads even if we currently don't use threads.

I believe I figured out why this happened, and will propose a change to eliminate the dependency.

Subtickets

Change History (6)

comment:1 in reply to: ↑ description Changed 9 years ago by jinmei

Replying to jinmei:

Right now we need to link some tests explicitly with libpthreads even if we currently don't use threads.

I believe I figured out why this happened, and will propose a change to eliminate the dependency.

Please review branches/trac345 (r2990).

threads were necessary in asio/asio/detail/tss_ptr.hpp as a result of instantation of io_service. We didn't need to link libpthread for b10-auth because other library (e.g. libsqlite3) implicitly required it.

I confirmed that the patch worked on bind10.isc.org (and that build failed on that machine without this patch and without linking libpthread).

This is the proposed changelog entry:

  98.	[build]		jinmei
	Disable threads in ASIO to minimize build time dependency.
	(Trac #345, rTBD).

comment:2 Changed 9 years ago by jinmei

  • Add Hours to Ticket changed from 0.0 to 0.5
  • Milestone set to y2 12 month milestone
  • Owner changed from jreed to UnAssigned
  • Status changed from new to reviewing
  • Total Hours changed from 0.0 to 0.5

comment:3 Changed 9 years ago by vorner

  • Owner changed from UnAssigned to vorner

comment:4 follow-up: Changed 9 years ago by vorner

The code seems simple and it seems to work, I think it can be merged.

comment:5 Changed 9 years ago by vorner

  • Owner changed from vorner to jinmei

comment:6 in reply to: ↑ 4 Changed 9 years ago by jinmei

  • Resolution set to fixed
  • Status changed from reviewing to closed

Replying to vorner:

The code seems simple and it seems to work, I think it can be merged.

Thanks for the review. Merged to trunk, closing ticket.

Note: See TracTickets for help on using tickets.