Opened 6 years ago

Closed 6 years ago

#3415 closed enhancement (complete)

Rename target installation directory from bind10 to kea

Reported by: tomek Owned by: UnAssigned
Priority: medium Milestone: Kea0.9
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Rename the target installation subdirectory from "bind10" to "kea".
Move files from "libexec" to "sbin".

This should be done after #3414 is done.

We originally assumed that we can do this once the bin10-ectomy is essentially complete. I may not be that simple. BIND10 is likely to be continued as a separate project under a new name. So it will ultimately be renamed as well, but for the time being there is a name conflict if someone wants to install both Kea and BIND10-renamed on the same box.

Subtickets

Change History (2)

comment:1 Changed 6 years ago by marcin

It looks like it is already covered by previous tickets.

comment:2 Changed 6 years ago by tomek

  • Resolution set to complete
  • Status changed from new to closed

Kea now installs in kea directory. Confirmed by Marcin and Tomek. Closing ticket.

Note: See TracTickets for help on using tickets.