Opened 9 years ago

Closed 9 years ago

#333 closed defect (fixed)

b10-xfrout and high cpu usage

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: xfrout Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

b10-xfrout cpu use is around 95 to 101% on my system.

Not sure yet where this happens.

The cpu use is low if no zones are loaded. The cpu use is low if can't do a zone transfer (incoming) because master doesn't allow it.

Subtickets

Change History (5)

comment:1 Changed 9 years ago by zhanglikun

ticket #349 may will fix the problem, when ticket #349 is merged into trunk, please retest this ticket.

comment:2 Changed 9 years ago by zhanglikun

The test should be done when ticket #349 and #352 are merged, since the two tickets will fix the high cpu usage problem in different way.

comment:3 Changed 9 years ago by jreed

The high cpu usage problem appears to be solved for me. But I am not closing this since #352 is not merged yet (per earlier comment).

comment:4 Changed 9 years ago by jreed

Oh I was wrong.

$ ps -www -p 7443 -o pcpu,command
%CPU COMMAND
99.1 /usr/pkg/bin/python3.1 /home/reed/opt/bind10/libexec/bind10-devel/b10-xfrout -v 

comment:5 Changed 9 years ago by jreed

  • Resolution set to fixed
  • Status changed from new to closed

Closing since tickets it depends on were closed now too.

Note: See TracTickets for help on using tickets.