Opened 6 years ago

Closed 6 years ago

#3285 closed defect (fixed)

Touching dependencies no longer calls gen-rdatacode.py

Reported by: muks Owned by: kean
Priority: very high Milestone: bind10-1.2-release-freeze
Component: libdns++ Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Touching dependencies no longer calls gen-rdatacode.py to regenerated the generated targets in libdns++. It seems this is due to the changes made in #3170:

commit e05189ee6561d06753b3bb2c8c6e4fad7c005625
Author: Kean Johnston <kean@isc.org>
Date:   Wed Sep 18 13:51:14 2013 +0200

    [3170] Slight correction to dependencies on Makefile

commit eaff454676513de3bf85d76c9ab724cf8191c649
Author: Kean Johnston <kean@isc.org>
Date:   Wed Sep 18 13:34:31 2013 +0200

    [3170] fix rulkes that were breaking parallel builds

This needs to be fixed at a high priority as changing rdata/ and other -placeholder files makes no difference and it's possible to commit and merge regressions due to bugs in these files without noticing it.

Subtickets

Change History (10)

comment:1 Changed 6 years ago by kean

  • Owner changed from UnAssigned to kean
  • Status changed from new to accepted

comment:2 Changed 6 years ago by kean

  • Owner changed from kean to UnAssigned
  • Status changed from accepted to reviewing

Found the problem and fixed it. The stamp file was not dependent on all of the possible inputs (or at least not the subset that was done pre #3170).

comment:3 Changed 6 years ago by kean

Just FYI, neither this patch, nor anything prior to #3170 had any dependencies on the contents of rdata. Only the dependencies on the *-placeholder files was fixed, which was the regression introduced.

comment:4 Changed 6 years ago by pselkirk

  • Owner changed from UnAssigned to kean

This works to the extent suggested. However, is there any reason not to make s-rdatacode dependent on $(EXTRA_DIST), since that includes the rdata files as well as the placeholder files?

comment:5 Changed 6 years ago by kean

  • Owner changed from kean to muks

No that is an excellent idea. If I make that change are you happy with the branch? Merge and close?

comment:6 Changed 6 years ago by muks

  • Owner changed from muks to kean

Make the change and please put the final branch to be merged to re-review.

comment:7 Changed 6 years ago by kean

  • Owner changed from kean to muks

Done. Ready for re-review.

comment:8 Changed 6 years ago by muks

  • Owner changed from muks to pselkirk

It is not my ticket. It should be assigned to Paul.

comment:9 Changed 6 years ago by pselkirk

  • Owner changed from pselkirk to kean

Perfect. Please merge.

comment:10 Changed 6 years ago by kean

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.