Opened 6 years ago

Closed 6 years ago

#3244 closed defect (wontfix)

Hardcoded UDP port causes test failures

Reported by: shane Owned by:
Priority: medium Milestone: Common Outstanding Tasks
Component: dhcp Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Low
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I was running the DHCP tests today and they failed. I happened to be on a device that had port 10001 used by some proprietary protocol (on the EdgeMAX EdgeRouter? Lite), and the tests failed. It took me quite a while to track down the failure to this root cause.

I'm not sure the best way to fix this in general, if indeed it needs fixing at all. Perhaps simply reporting that the failure was caused by failure to bind(), along with the address/port, might be enough. I would have tried "netstat -apn" if I had known that this might be the problem. :)

Subtickets

Change History (5)

comment:1 Changed 6 years ago by shane

Note this may be considered a general version of #2904.

comment:2 Changed 6 years ago by shane

I guess we should make a library which finds some unused ports for such tests and just that instead? Or maybe we need to run a program at the start of "make check" to find such ports? (I know neither of these is perfect, since ports can be used at any time by another program, but it would help...)

comment:3 Changed 6 years ago by kean

The problem is that as I currently understand lettuce (which is admittedly incomplete) the tests are not easily parameterized. There are also a number of data files that have specific port values in them. #2904 does mitigate the problem somewhat by using ports that are less likely to be occupied. Very even boundary ports like 10000, 10001 etc are high risk for some other thing using the port. Of course simply using a higher port is no *guarantee* but it does reduce the liklihood significantly.

comment:4 Changed 6 years ago by tomek

  • Milestone changed from New Tasks to Common Outstanding Tasks

Milestone New Tasks deleted

comment:5 Changed 6 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to old-bind10

This issue is related to bind10 code that is no longer part of Kea.

If you are interested in BIND10/Bundy framework or its DNS components,
please check http://bundy-dns.de.

Closing ticket.

Note: See TracTickets for help on using tickets.