Opened 6 years ago

Closed 6 years ago

#3167 closed defect (fixed)

[kean] BIND10 fail to start

Reported by: wlodekwencel Owned by:
Priority: high Milestone: Sprint-20131015
Component: ~Boss of BIND (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 2 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

after commit #3095 Bind fail to start.
Error:

  File "/usr/local/libexec/bind10/b10-init", line 72, in <module>
    import isc.cc
  File "/usr/local/lib/python3/dist-packages/isc/cc/__init__.py", line 2, in <module>
    from isc.cc.session import *
  File "/usr/local/lib/python3/dist-packages/isc/cc/session.py", line 25, in <module>
    import isc.log
ImportError: libb10-log.so.1: cannot open shared object file: No such file or directory

when I'm trying to run bindctl:

  File "/usr/local/bin/bindctl", line 24, in <module>
    from bindctl.bindcmd import *
  File "/usr/local/lib/python3/dist-packages/bindctl/bindcmd.py", line 28, in <module>
    import isc.config
  File "/usr/local/lib/python3/dist-packages/isc/config/__init__.py", line 1, in <module>
    from isc.config.ccsession import *
  File "/usr/local/lib/python3/dist-packages/isc/config/ccsession.py", line 39, in <module>
    from isc.cc import Session
  File "/usr/local/lib/python3/dist-packages/isc/cc/__init__.py", line 2, in <module>
    from isc.cc.session import *
  File "/usr/local/lib/python3/dist-packages/isc/cc/session.py", line 25, in <module>
    import isc.log
ImportError: libb10-log.so.1: cannot open shared object file: No such file or directory

my moves:
git clean -xfg
git pull
autoreconf
configure (without options)
make -j4

also problem confirmed by Tomek Mrugalski, same problem with:
git pull && git clean -fxd && autoreconf -i && ./configure --enable-generate-docs --with-gtest=/home/thomson/devel/gtest-1.6.0 --enable-logger-checks --with-dhcp-mysql && make -j8)

Subtickets

Change History (5)

comment:1 Changed 6 years ago by jreed

original problem is due to system not finding libraries. After running ldconfig (as root) I had new error same as tomek posted to jabber:

(07:15:24 AM) tomek: After running ldconfig, I get a different error message:
root@billabong:/home/thomson/devel/bind10# bind10
Traceback (most recent call last):
  File "/usr/local/libexec/bind10/b10-init", line 81, in <module>
    import isc.util.traceback_handler
  File "/usr/local/lib/python3/dist-packages/isc/util/traceback_handler.py", line 16, in <module>
    from isc.log_messages.util_messages import *
ImportError: No module named 'isc.log_messages.util_messages'

My fix is:

--- a/src/lib/python/isc/util/Makefile.am
+++ b/src/lib/python/isc/util/Makefile.am
@@ -2,8 +2,10 @@ SUBDIRS = . cio tests
 
 python_PYTHON =  __init__.py process.py socketserver_mixin.py file.py \
        traceback_handler.py
-BUILT_SOURCES = $(PYTHON_LOGMSGPKG_DIR)/work/util_messages.py
 python_PYTHON += address_formatter.py
+BUILT_SOURCES = $(PYTHON_LOGMSGPKG_DIR)/work/util_messages.py
+nodist_pylogmessage_PYTHON = $(PYTHON_LOGMSGPKG_DIR)/work/util_messages.py
+pylogmessagedir = $(pyexecdir)/isc/log_messages/
 
 EXTRA_DIST = util_messages.mes

Probably not seen on the build systems running lettuce because PYTHONPATH is set.

comment:2 Changed 6 years ago by muks

  • Estimated Difficulty changed from 0 to 2

comment:3 Changed 6 years ago by shane

  • Milestone changed from New Tasks to Sprint-20131015
  • Summary changed from BIND10 fail to start to [kean] BIND10 fail to start

comment:4 Changed 6 years ago by wlodekwencel

issue was fixed in hours after ticket creation, it can be close.

comment:5 Changed 6 years ago by kean

  • Resolution set to fixed
  • Status changed from new to closed

Verified with current master (0f7b304c340173ab49759f82ff7cbdf49aef5d7a). Closing.

Note: See TracTickets for help on using tickets.