Opened 7 years ago

Closed 7 years ago

#3050 closed defect (fixed)

"skip" flag not cleared if no callouts are attached to a hook

Reported by: stephen Owned by: stephen
Priority: medium Milestone: Sprint-DHCP-20130731
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

In the hooks system, the "skip" flag is set by a callout to indicate to the server that normal processing should be skipped when the callout returns. When the server calls the callouts attached to a hook, this flag is cleared before any calls are made. The problem is that this flag is only cleared if callouts are actually attached to the hook. If there are no callouts, the flag retains its previous value.

The fix is trivial - in CalloutManager::callCallouts(), unconditionally clear the "skip" flag on entry to the method.

Subtickets

Change History (6)

comment:1 Changed 7 years ago by stephen

  • Milestone changed from DHCP Outstanding Tasks to Sprint-DHCP-20130731

comment:2 Changed 7 years ago by stephen

  • Owner set to stephen
  • Status changed from new to assigned

comment:3 Changed 7 years ago by stephen

  • Owner changed from stephen to UnAssigned
  • Status changed from assigned to reviewing

Now ready for review.

comment:4 Changed 7 years ago by tomek

  • Owner changed from UnAssigned to tomek

comment:5 Changed 7 years ago by tomek

  • Owner changed from tomek to stephen

I did review code changes on trac3050 branch up to 35f65cf6f3644e5bc97d058ceffe87b2253305be commit.
The changes look good, but there is ChangeLog? entry missing.

The commit entry looks suitable for a ChangeLog? entry:

Always clear "skip" flag before calling any callouts on a hook

If you agree, please merge this code.

comment:6 Changed 7 years ago by stephen

  • Resolution set to fixed
  • Status changed from reviewing to closed

Suggested ChangeLog entry added. Merged in commit ff0b9b45869b1d9a4b99e785fbce421e184c2e93

Note: See TracTickets for help on using tickets.