Opened 7 years ago

Closed 7 years ago

#3049 closed defect (fixed)

Fix offset_ptr test in ax_boost_for_bind10.m4 and configure.ac

Reported by: muks Owned by: vorner
Priority: medium Milestone: Sprint-20130820
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 2 Add Hours to Ticket: 0
Total Hours: 0.94 Internal?: no

Description

  • Check the offset_ptr test in ax_boost_for_bind10.m4. It does not use -Werror during the compile.
  • Check the offset_ptr test in configure.ac (the code that follows AX_BOOST_FOR_BIND10). It should also test $werror_ok before calling AC_MSG_ERROR.

Subtickets

Change History (6)

comment:1 Changed 7 years ago by muks

  • Estimated Difficulty changed from 0 to 2

comment:2 Changed 7 years ago by muks

  • Milestone changed from Next-Sprint-Proposed to Sprint-20130820

comment:3 Changed 7 years ago by vorner

  • Owner changed from UnAssigned to vorner
  • Status changed from new to accepted

comment:4 follow-up: Changed 7 years ago by vorner

  • Owner changed from vorner to UnAssigned
  • Status changed from accepted to reviewing

Hello

I did what the ticket said. I don't think it is important enough for changelog entry (we don't know about any actual breakage that this might have caused).

However, I'm not completely sure the original was broken ‒ if the -Werror is not passed, the test does not fail and therefore we don't error. Do we need the change?

comment:5 in reply to: ↑ 4 Changed 7 years ago by muks

  • Owner changed from UnAssigned to vorner

Hi Michal

Replying to vorner:

I did what the ticket said. I don't think it is important enough for changelog entry (we don't know about any actual breakage that this might have caused).

*Nod*. I guess this was added for some very specific platform, and it was broken all this time, so I don't know if anyone even noticed it.

However, I'm not completely sure the original was broken ‒ if the -Werror is not passed, the test does not fail and therefore we don't error. Do we need the change?

Even if -Werror was passed, the test was compiled without -Werror at that point. So the test always passed (even if it generated a warning). Instead it should be compiled with -Werror all the time (even if -Werror is disabled) as it's just detection code.

I'm not sure if even this test is required as nobody seems to have noticed it.

The branch is fine, so please go ahead and merge it.

comment:6 Changed 7 years ago by vorner

  • Resolution set to fixed
  • Status changed from reviewing to closed
  • Total Hours changed from 0 to 0.94

Thank you, merged.

Note: See TracTickets for help on using tickets.