Opened 7 years ago

Closed 7 years ago

#2997 closed defect (fixed)

kea6 relay-forward bug

Reported by: wlodekwencel Owned by:
Priority: medium Milestone: Sprint-DHCP-20130606
Component: dhcp6 Version:
Keywords: dhcpv6 kea Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

kea6 reply with ADVERTISE, not RELAY-REPLY, on RELAY-FORWARD message.

Bug refers to:
RFC3315 Section 18.2.2.
If the original message was received in a Relay-forward message, the
server constructs a Relay-reply message with the Reply message in the
payload of a Relay Message option (see section 22.10).

wireshark capture included.

Subtickets

Attachments (1)

relay- (34.6 KB) - added by wlodekwencel 7 years ago.
relay-forward message

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by wlodekwencel

relay-forward message

comment:1 Changed 7 years ago by tomek

  • Milestone changed from New Tasks to Sprint-DHCP-20130606
  • Resolution set to fixed
  • Status changed from new to closed

I have looked at the problem and found the root cause. Wlodek was using bind10 1.1.0-beta2, which did include only the first part of the v6 relay work. The second one was merged shortly after 1.1.0-beta2 was released. (ChangeLog? entry 612 is the second one after 1.1.0-beta2 release).

I have used ISC Forge test v6.realy.message.solicit-advertise when trying to reproduce the problem. Note the misspelling in relay - it was reported to ISC Forge dev team.

This is a valid bug report and the bug was present in 1.1.0-beta2. It was fixed in ticket #2898 that was merged later. For that reason I'm closing it with FIXED status.

Thank you for your bug report and for writing ISC Forge tests!

Note: See TracTickets for help on using tickets.