Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#2948 closed enhancement (duplicate)

DHCPv6: implement Decline message support.

Reported by: marcin Owned by:
Priority: high Milestone: Kea1.0-beta
Component: dhcp6 Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Currently, Kea has a stub implementation for Decline messages. It creates empty Reply messages (with no options). The logic to process Decline messages should be added.

Subtickets

Change History (12)

comment:1 Changed 6 years ago by tomek

  • Milestone changed from DHCP Outstanding Tasks to DHCP-Kea1.0-alpha

comment:2 Changed 6 years ago by marcin

  • Priority changed from medium to low

comment:3 Changed 6 years ago by stephen

  • Milestone changed from DHCP-Kea0.9-alpha to DHCP-Kea0.9-beta

comment:4 Changed 6 years ago by tomek

  • Milestone changed from DHCP-Kea0.9 to DHCP-Kea1.0

comment:5 Changed 5 years ago by tomek

  • Milestone changed from Kea1.0 to Kea-proposed

One vendor asked about timelines for INFORM and DECLINE messages. We should reconsider our priorities here.

comment:6 Changed 5 years ago by tomek

  • Milestone changed from Kea-proposed to Kea1.0

As discussed on Kea meeting (2014-07-16), moving this to 1.0.

comment:7 Changed 5 years ago by tomek

  • Milestone changed from Kea1.0 to Kea0.9.1
  • Version set to git

comment:8 Changed 5 years ago by tomek

  • Milestone changed from Kea0.9.1 to Kea0.9.2

comment:9 Changed 5 years ago by tomek

  • Milestone changed from Kea0.9.2 to Kea1.0
  • Priority changed from low to medium

comment:10 Changed 4 years ago by marcin

  • Priority changed from medium to high

Moving to high per 1.0 tickets scrub. This ticket will be replaced with a bunch of tickets according to the Design.

comment:11 Changed 4 years ago by hschempf

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #3981

comment:12 Changed 4 years ago by tomek

  • Milestone changed from Kea1.0 to Kea1.0-beta

Milestone renamed

Note: See TracTickets for help on using tickets.