Opened 7 years ago

Closed 6 years ago

#2780 closed enhancement (duplicate)

Use socket creator to bind to privileged DHCP ports

Reported by: stephen Owned by:
Priority: medium Milestone: bind10-1.2-release-freeze
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

At the moment, the DHCP servers do not use the socket creator to bind to privileged ports. As a result BIND 10 needs to be started with "sudo" command.

This ticket modifies the servers to use the socket creator and remove the need for "sudo".

Subtickets

Change History (4)

comment:1 Changed 6 years ago by muks

See also #3188.

comment:2 Changed 6 years ago by tomek

  • Milestone changed from DHCP Outstanding Tasks to DHCP-Kea1.0-alpha

comment:3 Changed 6 years ago by muks

  • Milestone changed from DHCP-Kea1.0-alpha to Sprint-20131015

comment:4 Changed 6 years ago by stephen

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #3188, so this ticket has been closed.

Note: See TracTickets for help on using tickets.