Opened 7 years ago

Closed 7 years ago

#2741 closed defect (fixed)

assertion in statistics test_perzone_counters

Reported by: jreed Owned by:
Priority: medium Milestone: Sprint-20130305
Component: statistics Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: check if fixed Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

See
http://git.bind10.isc.org/~tester/builder/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/logs/unittests.out
http://git.bind10.isc.org/~tester/builder/BIND10-cppcheck/20130206173746-FreeBSD8-amd64-GCC/logs/unittests.out
http://git.bind10.isc.org/~tester/builder/BIND10-cppcheck/20130211135501-FreeBSD8-amd64-GCC/logs/unittests.out
This is the only three times I see this.

for pytest in counters_test.py ; do  echo Running test: $pytest ;  PYTHONPATH=/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/python/isc/log_messages:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/python/isc/cc:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/python:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/python:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/dns/python/.libs  LD_LIBRARY_PATH=/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/cryptolink/.libs:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/dns/.libs:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/dns/python/.libs:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/cc/.libs:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/config/.libs:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/log/.libs:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/util/.libs:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/exceptions/.libs:/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/datasrc/.libs:$LD_LIBRARY_PATH   B10_FROM_BUILD=/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build  B10_FROM_SOURCE=/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build  TESTDATASRCDIR=/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/python/isc/statistics/tests/testdata  /usr/local/bin/python /usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/python/isc/statistics/tests/$pytest || exit ;  done
Running test: counters_test.py
.....................F.....
======================================================================
FAIL: test_perzone_counters (__main__.TestCounters3)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/python/isc/statistics/tests/counters_test.py", line 224, in test_perzone_counters
    self.check_get_statistics()
  File "/usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/python/isc/statistics/tests/counters_test.py", line 181, in check_get_statistics
    self._statistics_data)
AssertionError: 
  {'zones': {'_SERVER_': {'axfrreqv4': 2,
                          'axfrreqv6': 2,
                          'ixfrreqv4': 2,
                          'ixfrreqv6': 2,
                          'soaoutv4': 2,
                          'soaoutv6': 2,
+                         'time_to_axfr': 0.0,
+                         'time_to_ixfr': 0.0,
                          'xfrfail': 2,
                          'xfrsuccess': 2},
             'example.com.': {'axfrreqv4': 2,
                              'axfrreqv6': 2,
                              'ixfrreqv4': 2,
                              'ixfrreqv6': 2,
                              'soaoutv4': 2,
                              'soaoutv6': 2,
                              'time_to_axfr': 0.0,
                              'time_to_ixfr': 0.0,
                              'xfrfail': 2,
                              'xfrsuccess': 2}}}

----------------------------------------------------------------------
Ran 27 tests in 1.497s

FAILED (failures=1)
*** Error code 1

Stop in /usr/home/jreed/builder/work/BIND10-cppcheck/20130214075001-FreeBSD8-amd64-GCC/build/src/lib/python/isc/statistics/tests.
*** Error code 1

Slightly different on one of them:

+                         'time_to_axfr': 0.0,
                          'time_to_ixfr': 0.000138,

Subtickets

Change History (3)

comment:1 Changed 7 years ago by naokikambe

This problem was caused by merging the statistics library on #2225. So I'd like to work on #2225 for this problem. (I've pushed trac2225_statistics_4(c2999ba) for it.) If the branch is merged and the error doesn't happen, I'll close this ticket.

comment:2 Changed 7 years ago by jelte

  • Estimated Difficulty changed from fixed? to check if fixed
  • Milestone changed from New Tasks to Sprint-20130305

comment:3 Changed 7 years ago by muks

  • Resolution set to fixed
  • Status changed from new to closed

Verified that this was merged to master branch in commit a5db81cca25ff24aebb7c1855ecd2ee40e2f129f.

The failure no longer occurs:
http://git.bind10.isc.org/~tester/builder/BIND10-cppcheck/20130219175501-FreeBSD8-amd64-GCC/logs/unittests.out

(There is a different unrelated failure in a different unittest, but this failure is fixed.)

Note: See TracTickets for help on using tickets.