Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2717 closed defect (duplicate)

new users added with b10-cmdctl-usermgr do not work

Reported by: cas Owned by:
Priority: medium Milestone:
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I've added new user accounts using "b10-cmdctl-usermgr" to /usr/local/share/bind10/cmdctl-accounts.csv

The new accounts names and password hashes appear in that file

but even after stopping and restarting all BIND 10 processes (including b10-cmdctl), I cannot login using any of the new accounts

This is on Version 1.0.0-beta

Subtickets

Change History (4)

comment:1 Changed 7 years ago by shane

  • Resolution set to duplicate
  • Status changed from new to closed

I think this is a duplicate of #2710.

comment:2 Changed 7 years ago by cas

Not sure if this is a duplicate. #2710 talks about that b10-cmdctl needs to be restarted, but for me it fails even after restarting b10-cmdctl (or the whole system).

It's like b10-cmdctl does not read the file at all.

comment:3 Changed 7 years ago by cas

Found the problem, it is in the first sentence above:

I've added new user accounts using "b10-cmdctl-usermgr" to /usr/local/share/bind10/cmdctl-accounts.csv

new accounts needs to be added to "/usr/local/etc/bind10/cmdctl-accounts.csv", not "/usr/local/share/bind10/cmdctl-accounts.csv"

this information is in the BIND 10 guide, but I missed it. But might be good to have b10-cmdctl-usermgr to default to the correct file (but there is a ticket for this somewhere already)

comment:4 Changed 7 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.