Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#2702 closed defect (fixed)

Dhcp4 server not correctly using hwaddr to renew existing leases, grants new lease each time

Reported by: tmark Owned by: UnAssigned
Priority: very high Milestone: Sprint-DHCP-20130509
Component: dhcp4 Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: High
Sub-Project: DHCP Feature Depending on Ticket: lease renewal
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Dhcp4 server is not correctly locating existing leases, and is instead issuing new leases. So a client setup to just get and renew a single lease, instead gets a brand new lease every time.

To reproduce, set up a dhclient -4, with all else default or see v4.stability test

Subtickets

Attachments (1)

v4.stability.1.tgz (312.5 KB) - added by tmark 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by tmark

comment:1 Changed 7 years ago by tomek

Marcin has found the cause of this problem. The code was not renewing properly for clients without client-id. I have implemented a candidate fix.

The code is available on trac2702 branch.

comment:2 Changed 7 years ago by tomek

  • Status changed from new to reviewing

comment:3 Changed 7 years ago by tomek

  • Owner changed from tomek to UnAssigned

comment:4 Changed 7 years ago by tomek

  • Component changed from Unclassified to dhcp4
  • Milestone changed from New Tasks to Sprint-DHCP-20130214
  • Sub-Project changed from DNS to DHCP

comment:5 Changed 7 years ago by tomek

  • Resolution set to fixed
  • Status changed from reviewing to closed

Fix merged.

comment:6 Changed 7 years ago by jwright

After discussion with Jeremy, myself, Tomek and Thomas, we need to generate a new ticket to track writing a unit test for this issue. That new ticket is Ticket #2722: http://bind10.isc.org/ticket/2722.

comment:7 Changed 7 years ago by jwright

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 Changed 7 years ago by jwright

  • Milestone Sprint-DHCP-20130214 deleted

comment:9 Changed 6 years ago by tomek

  • Resolution set to fixed
  • Status changed from reopened to closed

This has been merged a long time ago as part of #2701.

comment:10 Changed 6 years ago by tomek

  • Milestone set to Sprint-DHCP-20130509
Note: See TracTickets for help on using tickets.