Opened 9 years ago

Closed 9 years ago

#263 closed defect (duplicate)

cfgmrg tests have errors, but doesn't fail

Reported by: jreed Owned by: jelte
Priority: medium Milestone:
Component: configuration Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket:
Total Hours: Internal?: no

Description

[b10-cfgmgr] Unable to write config file; configuration not stored: [Errno 13] Permission denied: '/backup/isc-work-svn/svn/trunk/bind10-devel-20100602/_build/../src/lib/config/testdata/b10-config.db.nO_jFh'
...........[b10-cfgmgr] Unable to write config file; configuration not stored: [Errno 13] Permission denied: '/backup/isc-work-svn/svn/trunk/bind10-devel-20100602/_build/../src/lib/config/testdata/b10-config.db.Q8B3YM'

The cfgmgr_test.py test fails in a read-only src tree. But the framework doesn't fail. I only noticed this manually reviewing.

Two problems: the test framework should fail -- make check should fail; and should use the build tree for writing config files.

Subtickets

Change History (2)

comment:1 Changed 9 years ago by jelte

  • billable set to 0
  • Estimated Difficulty set to 0.0
  • Internal? unset

Should we simply skip the automatic write_config() call at the end? (and only write back the configuration the moment something is successfully changed, which it already does)

comment:2 Changed 9 years ago by jreed

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #222

Note: See TracTickets for help on using tickets.