Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2581 closed defect (duplicate)

bindctl needs to be initialized before lettuce tests can run

Reported by: shane Owned by:
Priority: medium Milestone:
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Low
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I tried to run lettuce tests, but got the following error:

ind10 module Auth should be running                                    # features/terrain/bind10_control.py:324
/usr/lib/python3.2/getpass.py:83: GetPassWarning: Can not control echo on the terminal.
  passwd = fallback_getpass(prompt, stream)
Warning: Password input may be echoed.
Password: 

I was able to get the tests to run by:

  1. starting BIND 10 (in the build tree)
  2. logging in with bindctl (again, in the build tree)

This should either be documented, or perhaps we should explicitly pass user/password to bindctl within the lettuce tests.

Subtickets

Change History (4)

comment:1 Changed 7 years ago by shane

  • Defect Severity changed from N/A to Low

comment:2 Changed 7 years ago by shane

Duplicate of #2341!

comment:3 Changed 7 years ago by shane

  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 Changed 7 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.