Opened 7 years ago

Closed 6 years ago

#2569 closed defect (wontfix)

RR class (CH) does not match the zone class (CLASS0)

Reported by: jreed Owned by:
Priority: medium Milestone: DNS Outstanding Tasks
Component: data source Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: High
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

2012-12-19 21:11:07.221 ERROR [b10-auth.auth/94094] AUTH_DATASRC_CLIENTS_BUILDER_RECONFIGURE_DATASRC_ERROR Error setting up data source: Unknown uncaught exception from static createInstance: RR class (CH) does not match the zone class (CLASS0) in /usr/local/share/bind10/static.zone at line 10

The static zone has:

BIND.           0   CH  SOA bind. authors.bind. 0 28800 7200 604800 86400

(This comes from the installation.)

My configuration had:

> config show all data_sources/classes/CH
data_sources/classes/CH[0]/type "static"        string
data_sources/classes/CH[0]/params       "/usr/local/share/bind10/static.zone"  any
data_sources/classes/CH[0]/cache-enable false   boolean
data_sources/classes/CH[0]/cache-zones  []      list

Subtickets

Change History (7)

comment:1 Changed 7 years ago by jreed

This is how this problem was seen:

Original configuration had:

data_sources/classes/CH[0]/type "static"        string
data_sources/classes/CH[0]/params       "/usr/local/share/bind10-devel/static.zone"  any
data_sources/classes/CH[0]/cache-enable false   boolean
data_sources/classes/CH[0]/cache-zones  []      list

This caused the error for each of my auth servers:

2012-12-19 21:06:32.458 ERROR [b10-auth.auth/94095] AUTH_DATASRC_CLIENTS_BUILDER
_RECONFIGURE_DATASRC_ERROR Error setting up data source: Unknown uncaught except
ion from static createInstance: Failed to open master file: /usr/local/share/bin
d10-devel/static.zone: No such file or directory

Note the old params location. So I did with bindctl:

> config set data_sources/classes/CH[0]/params "/usr/local/share/bind10/static.zone"
> config commit

Then that "RR class (CH) does not match the zone class (CLASS0)" error occurred.

When I restart all of bind10 with this new configuration (correct file path) I don't get this mismatch error.

Hopefully this can show how to reproduce it.

comment:2 follow-up: Changed 7 years ago by shane

  • Estimated Difficulty changed from 5 to 0
  • Milestone New Tasks deleted

So it is possible to crash the server by putting an incorrect source file? That is bad.

If the problem is actually something related to Chaos class, then I'm less worried.

comment:3 in reply to: ↑ 2 Changed 7 years ago by jinmei

Replying to shane:

So it is possible to crash the server by putting an incorrect source file? That is bad.

The server doesn't crash, if I read it correctly. It simply failed to
load data sources. And it's not about putting an incorrect file; it's
about some kind of installation failure by which the static zone file
doesn't exist where the server expects.

comment:4 Changed 6 years ago by shane

  • Milestone set to Sprint-20131015
  • Summary changed from RR class (CH) does not match the zone class (CLASS0) to [kean] RR class (CH) does not match the zone class (CLASS0)

Probably we don't mind so much about the specific error, since this is about a change when upgrading and is over 11 months old.

But, we should probably make it so that a misconfiguration of the static data source is caught and the server does not crash, but operates without that data source.

comment:5 Changed 6 years ago by kean

  • Summary changed from [kean] RR class (CH) does not match the zone class (CLASS0) to RR class (CH) does not match the zone class (CLASS0)

comment:6 Changed 6 years ago by stephen

  • Milestone changed from bind10-1.2-release-freeze to DNS Outstanding Tasks

comment:7 Changed 6 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed

Kea project is DHCP only. Closing stale DNS-related tickets.

If you're interested in DNS, please see Bundy project http://bundy-dns.de

Note: See TracTickets for help on using tickets.