Opened 7 years ago

Closed 6 years ago

#2556 closed defect (wontfix)

output from bind10 (when Resolver shutdown)

Reported by: jreed Owned by: jreed
Priority: medium Milestone: DNS Outstanding Tasks
Component: resolver Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Medium
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 5 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I am using master as of yesterday. It includes #2445 ("The system no longer prints initial log messages to stdout ...").

When I do "Resolver shutdown" in bindctl, I get output from bind10:

pure virtual method called
terminate called without an active exception
pure virtual method called
terminate called without an active exception
pure virtual method called
terminate called without an active exception

(I did it three times.)

I don't know where this comes from, but I guess it is b10-resolver. I didn't reproduce by using "Auth shutdown".

In jabber, jinmei mentioned: unimplemented pure virtual should normally be detected at compile time ... I suspect it's some system-dependent run time error ... something like the use of incompatible binary

Subtickets

Change History (9)

comment:1 Changed 7 years ago by jinmei

So I suggest you re-install everything and try again.

comment:2 Changed 7 years ago by jreed

I reinstalled again since then. The problem still continues. I did not clear out my install directory and I didn't clone a new nor clean out my source tree.

comment:3 Changed 7 years ago by jwright

  • Defect Severity changed from N/A to Medium
  • Milestone changed from New Tasks to Next-Sprint-Proposed

comment:4 Changed 7 years ago by jreed

  • Milestone Next-Sprint-Proposed deleted

I removed the milestone. This is not a priority for the release and this code after the release is expected to have a major rewrite.

comment:5 Changed 7 years ago by jinmei

this is probably the same problem as #2942.

comment:6 follow-up: Changed 7 years ago by shane

  • Owner set to jreed
  • Status changed from new to assigned

Jeremy can you check if this is resolved? In principle #2946 resolves this.

comment:7 in reply to: ↑ 6 Changed 7 years ago by jreed

Replying to shane:

Jeremy can you check if this is resolved? In principle #2946 resolves this.

The problem still exists with today's master (and with 1.1.0 release).

I did a "Resolver shutdown" and I receive this output (not from bindctl, but from bind10):

pure virtual method called
terminate called without an active exception

comment:8 Changed 6 years ago by stephen

  • Milestone set to DNS Outstanding Tasks

comment:9 Changed 6 years ago by tomek

  • Resolution set to wontfix
  • Status changed from assigned to closed

DNS and BIND10 framework is outside of scope for Kea project.
The corresponding code has been removed from Kea git repository.
If you want to follow up on DNS or former BIND10 issues, see
http://bundy-dns.de project.

Closing ticket.

Note: See TracTickets for help on using tickets.