Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2553 closed defect (duplicate)

log4cplus:WARN RollingFileAppender: MaxFileSize property value is too small. Resetting to 204800.

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: logging Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 3 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

One of my log files has several of:

log4cplus:WARN RollingFileAppender?: MaxFileSize? property value is too small. Resetting to 204800.

Note that it does not use the standard logging format (time stamp, component, etc).

I caused it with typo:

Logging/loggers[0]/output_options[0]/maxsize 104857 integer

I meant it to be 1048576.

Subtickets

Change History (4)

comment:1 Changed 7 years ago by jinmei

It's leaking log4cplus's own warning. I thought I opened a ticket about it.

comment:2 Changed 7 years ago by shane

This is basically a duplicate of #1081.

comment:3 Changed 7 years ago by jreed

  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 Changed 7 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.