Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2515 closed defect (invalid)

normal Auth shutdown causes ERROR

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: ~Boss of BIND (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I did a "Auth shutdown" with multiple b10-auth servers enabled.

My logs showed:

2012-11-28 20:27:46.502 INFO  [b10-auth.auth] AUTH_DATASRC_CLIENTS_BUILDER_STOPPED data source builder thread stopped
2012-11-28 20:27:46.951 INFO  [b10-boss.boss] BIND10_LOST_SOCKET_CONSUMER consumer 35 of sockets disconnected, considering all its sockets closed
2012-11-28 20:27:47.075 INFO  [b10-boss.boss] BIND10_PROCESS_ENDED process 34390 of b10-auth-6 ended with status 0
2012-11-28 20:27:47.082 ERROR [b10-boss.boss] BIND10_COMPONENT_FAILED component b10-auth-6 (pid 34390) failed: process exited normally with exit status 0
2012-11-28 20:27:47.082 INFO  [b10-boss.boss] BIND10_COMPONENT_START component b10-auth-6 is starting
2012-11-28 20:27:47.082 INFO  [b10-boss.boss] BIND10_STARTING_PROCESS starting process b10-auth
2012-11-28 20:27:47.192 INFO  [b10-boss.boss] BIND10_PROCESS_ENDED process 34389 of b10-auth-7 ended with status 0
2012-11-28 20:27:47.192 ERROR [b10-boss.boss] BIND10_COMPONENT_FAILED component b10-auth-7 (pid 34389) failed: process exited normally with exit status 0

(repeated for the other auth process too)

I am opening this ticket since "ERROR" should not be logged for a normal exit.

Subtickets

Change History (3)

comment:1 Changed 7 years ago by vorner

  • Resolution set to invalid
  • Status changed from new to closed

But this is _not_ a normal exit. The boss not expect the auth server to terminate
and it needs to restart it therefore. In that sense, it is an error.

The problem here is that shutdown is an internal command which should never
ever be called by a user. We need to be able to hide such commands from user. I
think there's a ticket for that somewhere, but I don't know the number. Anyway,
the ticket is probably waiting as part of the „configuration data rewrite“.

We also need a command to temporarily shut down a component or to restart it in
Boss.

I hope it is not rude to close it as invalid.

comment:2 Changed 7 years ago by jreed

This is a duplicate of #1734 (nine months old).

comment:3 Changed 7 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.