Opened 7 years ago

Closed 6 years ago

#2511 closed defect (wontfix)

defining a data_sources/classes/IN disables the builtin CH

Reported by: jreed Owned by:
Priority: medium Milestone: DNS Outstanding Tasks
Component: b10-auth Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Medium
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 2 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description (last modified by jreed)

By default, b10-auth has version.bind.

But when configuring a

"data_sources": {"classes": {"IN": [{"params": {
...
}

(and that works)

The CH class seems to be gone. At least queries for it now return REFUSED.

I thought there was a ticket already about this, but I can't find it now.

This may be known behaviour since setting data_sources in the configuration overrides the default settings. I think that is confusing. But maybe the fix is just to document it better (or point me to it).

Subtickets

Change History (6)

comment:1 Changed 7 years ago by jwright

  • Defect Severity changed from N/A to Medium
  • Milestone New Tasks deleted

comment:2 Changed 7 years ago by jinmei

I believe it's actually the intended behavior. So this is either subject of
a discussion of whether to change it, or of documenting the current behavior
if it's really confusing and not yet documented. (until then I don't think
it's estimatable).

comment:3 Changed 7 years ago by vorner

I believe people should not use config set data_sources big-fat-JSON-here,
but do it with commands like config add data_sources/IN example.org. Then it
doesn't remove anything.

If someone really overrides default config, then it should be expected to be
overridden and doing anything else could be very confusing.

comment:4 Changed 7 years ago by jreed

  • Description modified (diff)

comment:5 Changed 6 years ago by stephen

  • Milestone set to DNS Outstanding Tasks

comment:6 Changed 6 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed

DNS and BIND10 framework is outside of scope for Kea project.
The corresponding code has been removed from Kea git repository.
If you want to follow up on DNS or former BIND10 issues, see
http://bundy-dns.de project.

Closing ticket.

Note: See TracTickets for help on using tickets.