Opened 7 years ago

Closed 5 years ago

#2509 closed defect (wontfix)

extra comma in configuration and zombie cfgmgr

Reported by: jreed Owned by:
Priority: medium Milestone: Remaining BIND10 tickets
Component: ~Boss of BIND (obsolete) Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Low
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description (last modified by jreed)

I generated a list of data sources and my params had a trailing comma.
This caused cfgmgr to become a defunct zombie (on Linux) process.

I only realized since bind10 every second does log BIND10_WAIT_CFGMGR. I tested with different wait times.

2012-11-26 16:32:16.584 DEBUG [b10-boss.boss] BIND10_WAIT_CFGMGR waiting for configuration manager process to initialize
2012-11-26 16:32:17.584 ERROR [b10-boss.boss] BIND10_COMPONENT_START_EXCEPTION component cfgmgr failed to start: Configuration manager process has not started
2012-11-26 16:32:17.584 ERROR [b10-boss.boss] BIND10_COMPONENT_FAILED component cfgmgr (pid None) failed: unknown condition
2012-11-26 16:32:17.584 FATAL [b10-boss.boss] BIND10_COMPONENT_UNSATISFIED component cfgmgr is required to run and failed
2012-11-26 16:32:17.584 ERROR [b10-boss.boss] BIND10_CONFIGURATOR_PLAN_INTERRUPTED configurator plan interrupted, only 2 of 3 done
2012-11-26 16:32:17.584 INFO  [b10-boss.boss] BIND10_KILLING_ALL_PROCESSES killing all started processes

Here is an example:

{"version": 2,
"Auth": {"listen_on": [{"port": 5300, "address": "127.0.0.1"}]},
"Boss": {"components": {"b10-auth": {"kind": "needed", "special": "auth"}}},
"data_sources": {"classes": {"IN": [{"params": {
"1.example":
"/home/jreed/test5-zones/1.example-canonical",
"2.example":
"/home/jreed/test5-zones/2.example-canonical",
}, "type": "MasterFiles", "cache-enable": true}]}}}

I do get a message like:

2012-11-26 16:51:18.501 FATAL [b10-cfgmgr.cfgmgr] CFGMGR_DATA_READ_ERROR error reading configuration database from disk: Configuration file out of date or corrupt, please update or remove /home/jreed/dnsbench/work/origin/bind10-20121115-release/20121126190544/install/var/bind10-devel/b10-config.db

But that may be overlooked after many BIND10_WAIT_CFGMGR lines.

Subtickets

Change History (7)

comment:1 Changed 7 years ago by jreed

  • Summary changed from trailing comma in data_sources/classes/IN params list and zombie cfgmgr to extra comma in configuration and zombie cfgmgr

This can happen with other configs also, like:

{"version": 2,
"Auth": {"listen_on": [{"port": 5300, "address": "127.0.0.1"}]},
"Boss": {"components": {"b10-auth": {"kind": "needed", "special": "auth"}}},
}

Notice the last comma.

comment:2 Changed 7 years ago by jwright

Jeremy, did you edit the config file directly, or did this come from bindctl?

comment:3 Changed 7 years ago by jreed

I created the problem configuration with a script. the second example I did manually. This ticket is about cfgmgr hanging.

comment:4 Changed 7 years ago by jreed

  • Description modified (diff)

comment:5 Changed 7 years ago by shane

  • Defect Severity changed from N/A to Low
  • Milestone New Tasks deleted

Hm... so cfgmgr died and the boss didn't reap it quickly? Which delayed the system shutdown?

Perhaps the boss was trying to use the cfgmgr itself in some way? In any case, if this is the problem, and it is reproducible, then we can have a look. I consider it a low priority though, since it requires going under the hood to create the problem.

comment:6 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:7 Changed 5 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to old-bind10

This issue is related to bind10 code that is no longer part of Kea.

If you are interested in BIND10/Bundy framework or its DNS components,
please check http://bundy-dns.de.

Closing ticket.

Note: See TracTickets for help on using tickets.