Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2501 closed enhancement (fixed)

python 3.3 is available

Reported by: fdupont Owned by: jreed
Priority: medium Milestone:
Component: Unclassified Version:
Keywords: Cc: jwright@…
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

In the top configure.ac line 237:

m4_define([_AM_PYTHON_INTERPRETER_LIST], [python python3.2 python3.1 python3])

Does it work with python3.3? BTW why no anticipate to any new version of python3, i.e., python3.[1-9]?

Subtickets

Change History (6)

comment:1 Changed 7 years ago by jwright

  • Cc jwright@… added
  • Defect Severity changed from High to N/A
  • Milestone New Tasks deleted
  • Owner set to jreed
  • Priority changed from high to medium
  • Status changed from new to assigned
  • Type changed from defect to enhancement

We need to get Jeremy/Jeff? to set up a build environment that specifically tests the different versions of Python. Shane and I spoke about this and agreed that we should not put this change in until the new version of Python (3.3) has been tested.

We may also want to consider setting up a listener (RSS?) on the python announcement mailing list so that when a new version is released, we test it again.

comment:2 Changed 7 years ago by jreed

Python 3.3.0 was used on the new CentOS5-x86_64-GCC (but it has problems #2621). I am using --with-pythonpath. Once this is confirmed to work, I will add to the configure.ac list and start using 3.3.0 again on that build system.

Also looks like python 3.3 was used in #2249 (referencing https://lists.isc.org/pipermail/bind10-users/2012-September/000391.html).

comment:3 Changed 7 years ago by jreed

Also see #2622 and #2623 for more python 3.3.0 issues.

comment:4 Changed 7 years ago by jwright

  • Milestone set to Next-Sprint-Proposed

Moving back to Next-Sprint-Proposed, since other Python 3.3 tickets (2621, 2622, 2623) are being targeted there as well.

comment:5 Changed 7 years ago by jreed

  • Resolution set to fixed
  • Status changed from assigned to closed

added in commit 9bb9dbe6234769cbe525c24887eefe16ef1d7cee
I didn't add open-ended but I am closing this ticket for now.

comment:6 Changed 7 years ago by shane

  • Milestone Next-Sprint-Proposed deleted
Note: See TracTickets for help on using tickets.