Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2496 closed defect (duplicate)

dhcp6 test fails in: test_alive (__main__.TestDhcpv6Daemon)

Reported by: muks Owned by:
Priority: medium Milestone:
Component: dhcp6 Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I got a failure with current master in dhcp6 tests:

for pytest in dhcp6_test.py ; do \
echo Running test: $pytest ; \
 \
B10_LOCKFILE_DIR_FROM_BUILD=/home/muks/bind10 \
PYTHONPATH=/home/muks/bind10/src/lib/python/isc/log_messages:/home/muks/bind10/src/lib/python:/home/muks/bind10/src/lib/python:/home/muks/bind10/src/bin:/home/muks/bind10/src/bin/bind10:/home/muks/bind10/src/lib/util/io/.libs \
	/usr/bin/python3.2 /home/muks/bind10/src/bin/dhcp6/tests/$pytest || exit ; \
done
Running test: dhcp6_test.py
Note: Purpose of some of the tests is to check if DHCPv6 server can be started,
      not that is can bind sockets correctly. Please ignore binding errors.
Running command: ../b10-dhcp6 -v
No data available from stdout
No data available on stderr
Process finished, return code=-15, stdout=0 bytes, stderr=0 bytes
/home/muks/bind10/src/bin/dhcp6/tests/dhcp6_test.py:143: ResourceWarning: unclosed file <_io.FileIO name=9 mode='wb'>
  (returncode, output, error) = self.runCommand(["../b10-dhcp6", "-v"])
FCheck that specifying port number 0 is not allowed.
Running command: ../b10-dhcp6 -p 0
Process finished, return code=1, stdout=0 bytes, stderr=240 bytes
/home/muks/bind10/src/bin/dhcp6/tests/dhcp6_test.py:150: ResourceWarning: unclosed file <_io.FileIO name=11 mode='wb'>
  (returncode, output, error) = self.runCommand(['../b10-dhcp6', '-p', '0'])
.Check that -p option is check against bogus port number (999999).
Running command: ../b10-dhcp6 -p 999999
Process finished, return code=1, stdout=0 bytes, stderr=245 bytes
/home/muks/bind10/src/bin/dhcp6/tests/dhcp6_test.py:172: ResourceWarning: unclosed file <_io.FileIO name=13 mode='wb'>
  (returncode, output, error) = self.runCommand(['../b10-dhcp6', '-p','999999'])
.Check that -p option is check against bogus port number (123garbage).
Running command: ../b10-dhcp6 -p 123garbage
Process finished, return code=1, stdout=0 bytes, stderr=249 bytes
/home/muks/bind10/src/bin/dhcp6/tests/dhcp6_test.py:183: ResourceWarning: unclosed file <_io.FileIO name=15 mode='wb'>
  (returncode, output, error) = self.runCommand(['../b10-dhcp6', '-p','123garbage'])
.Check that -p option requires a parameter.
Running command: ../b10-dhcp6 -p
Process finished, return code=1, stdout=0 bytes, stderr=276 bytes
/home/muks/bind10/src/bin/dhcp6/tests/dhcp6_test.py:161: ResourceWarning: unclosed file <_io.FileIO name=17 mode='wb'>
  (returncode, output, error) = self.runCommand(['../b10-dhcp6', '-p'])
.Check that specifying unprivileged port number will work.
Running command: ../b10-dhcp6 -v -s -p 10547
Process finished, return code=-15, stdout=167 bytes, stderr=530 bytes
/home/muks/bind10/src/bin/dhcp6/tests/dhcp6_test.py:195: ResourceWarning: unclosed file <_io.FileIO name=19 mode='wb'>
  (returncode, output, error) = self.runCommand(['../b10-dhcp6', '-v', '-s', '-p', '10547'])
.Check that connection to BIND10 msgq can be disabled.
Running command: ../b10-dhcp6 -v -s -p 10547
Process finished, return code=-15, stdout=167 bytes, stderr=530 bytes
/home/muks/bind10/src/bin/dhcp6/tests/dhcp6_test.py:204: ResourceWarning: unclosed file <_io.FileIO name=21 mode='wb'>
  (returncode, output, error) = self.runCommand(['../b10-dhcp6', '-v', '-s', '-p', '10547'])
.
======================================================================
FAIL: test_alive (__main__.TestDhcpv6Daemon)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/muks/bind10/src/bin/dhcp6/tests/dhcp6_test.py", line 145, in test_alive
    self.assertEqual(output_text.count("DHCP6_STARTING"), 1)
AssertionError: 0 != 1

----------------------------------------------------------------------
Ran 7 tests in 7.123s

FAILED (failures=1)
make[6]: *** [check-local] Error 1
make[6]: Leaving directory `/home/muks/bind10/src/bin/dhcp6/tests'
make[5]: *** [check-am] Error 2
make[5]: Leaving directory `/home/muks/bind10/src/bin/dhcp6/tests'
make[4]: *** [check-recursive] Error 1
make[4]: Leaving directory `/home/muks/bind10/src/bin/dhcp6'
make[3]: *** [check] Error 2
make[3]: Leaving directory `/home/muks/bind10/src/bin/dhcp6'
make[2]: *** [check-recursive] Error 1
make[2]: Leaving directory `/home/muks/bind10/src/bin'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/home/muks/bind10/src'
make: *** [check-recursive] Error 1
[muks@jurassic bind10]$ 

Platform is Fedora 17 x86_64. gcc version 4.7.2 20120921 (Red Hat 4.7.2-2) (GCC).

Subtickets

Change History (5)

comment:1 Changed 7 years ago by muks

It's not reproducible every time.

comment:2 follow-up: Changed 7 years ago by jelte

I think this is the same issue as #2410

comment:3 in reply to: ↑ 2 Changed 7 years ago by muks

Replying to jelte:

I think this is the same issue as #2410

In light of that comment: my system was running an rsync backup from one disk to another (encrypted) while make check was running. You could say it was pretty heavily CPU and IO loaded.

comment:4 Changed 7 years ago by stephen

  • Resolution set to duplicate
  • Status changed from new to closed

It is a duplicate of #2410.

comment:5 Changed 7 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.